Internal server error 500 after update to 1.4.1

This morning I received a message from Hestia panel stating:

“XXXX has been upgraded from Hestia Control Panel v1.3.5 to v1.4.1.”

Since that time, all hosted web pages are inaccessible and it returns that 500 error.

# Internal Server Error

Oops! Something went wrong.

The server encountered an internal error or misconfiguration and was unable to complete your request.

Error Code: 500

I have tried to access the ftp of one of the web pages and it works, but not the phpmyadmin access (through the hestia panel).

I can’t access other users with the administrator login as I did before and I don’t know if there is any other problem as said in other recent posts.

My system is Ubuntu 20.04 (x86_64)

I am quite novice with console so I need to know what I should be doing to detect what is the problem and the possible solution.

Can you help me?

Check /home/user/web/doman/logs and check for any strange / out of the ordinary.

The email that i received say:

Installation log: /root/hst_backups/270520210125/hst-upgrade-270520210125.log
the question I have is how do I access this .log file?

From the hestiacp panel I can’t find the directory. is it from the ubuntu console? how can I locate that in ubuntu?

I already said that these questions are very novice but I’m sure with some help you can solve the problem.

i find this log report in one of all websites (but ALL websites down, not only one):

in this two files appear a code of 1 page composed in html like this (i erased some personal data):

<!doctype html>
<html lang="es">

<head>
  <meta charset="utf-8">
<title>xxx.xxx.xxx.xxx:8083 - USUARIO - Panel de control Hestia</title>  <link rel="icon" href="/images/favicon.ico" type="image/x-icon">
<link type="text/css" rel="stylesheet" href="/css/themes/default.min.css?1622114076" rel="preload" />
<!-- Load custom theme -->
  <!-- Load HestiaCP-shipped themes (minified, updated/overwritten with updates) - ($HESTIA/web/css/themes/*.min.css) -->
  <link type="text/css" rel="stylesheet" href="/css/themes/dark.min.css?864120765" rel="preload" />
  <!-- Load custom theme files ($HESTIA/web/css/themes/custom/*.css) -->
  <link type="text/css" rel="stylesheet" href="/css/themes/custom/dark.css?453246515" rel="preload" />
<link type="text/css" href="/css/dependencies/animate.min.css?1622114076" rel="stylesheet" rel="preload" />
<link type="text/css" href="/css/dependencies/jquery-custom-dialogs.css?1622114076" rel="stylesheet" rel="preload" />
<link type="text/css" href="/css/dependencies/fontawesome.min.css?1622114076" rel="stylesheet" rel="preload" />  <script type="text/javascript" src="/inc/jquery/jquery-3.5.1.min.js"></script>   <script>
    //
    //  GLOBAL SETTINGS
    //
    var GLOBAL = {};
    GLOBAL.FTP_USER_PREFIX = '';
    GLOBAL.DB_USER_PREFIX = '';
    GLOBAL.DB_DBNAME_PREFIX = '';
    GLOBAL.AJAX_URL = '';
  </script>
</head>

<body class="body-user lang-es">
  <div class="hidden" id="token" token="xxxxxxxxxxxxxxx19ea610d9xxxxxxx"></div>
<a href="#" class="to-top" title="Arriba">
	<i class="fas fa-arrow-up"></i>
</a>
<a href="#" class="to-shortcuts" title="Atajos">
	<i class="fas fa-keyboard"></i>
</a>

<div class="l-header">
	<div class="l-center">
		<!-- Logo / Home Button -->
		<a href="/list/user/" class="l-logo" title="Panel de control Hestia"></a>

		<!-- Left Menu -->
		<div class="l-menu clearfix noselect">
			<!-- Records tab -->
			<div class="l-menu__item       l-menu__item--active"><a href="/list/user/"><i class="fas fa-tasks panel-icon"></i>Registros</a></div>
			
			<!-- File Manager tab -->
													<div class="l-menu__item "><a href="/fm/"><i class="fas fa-folder-open panel-icon"></i>Ficheros</a></div>
										
			<!-- Statistics tab-->
			<div class="l-menu__item "><a href="/list/stats/"><i class="fas fa-chart-line panel-icon"></i>Estadísticas</a></div>
		</div>

		<!-- Right Menu -->
		<div class="l-profile noselect">
			<div class="l-menu__item">
				<!-- Logged in as / Usage Statistics Overview -->
				<span class="pill usage">
										<span class="label-space-right"><i class="fas fa-user-tie icon-pad-right" title="Autenticado como: XXXXXXXXXXX"></i><b>admin</b></span>
					<span class="label-space-right"><i class="fas fa-hdd icon-pad-right" title="Disco: 296 mb"></i><b>296</b> mb</span>
					<span><i class="fas fa-exchange-alt icon-pad-right" title="Ancho de Banda: XXX mb"></i><b>10</b> mb</span>
				</span>
			</div>

			<!-- Notifications -->
							<div class="l-menu__item">
					<a title="Notificaciones" class="l-profile__notifications  updates">
						<i class="fas fa-bell  animated extended swing status-icon orange"></i>
					</a>
				</div>
			
			<!-- Server Settings -->
											
					<div class="l-menu__item    "><a href="/list/server/" class="l-profile__serversettings" title="Servidor"><i class="fas fa-cog"></i></a></div>
							
			<!-- Edit User -->
												<div class="l-menu__item"><a href="/edit/user/?user=admin&token=XXXXXXXXXXXXXXXXXXXXXXX" title="admin (XXXXXX)" class="l-profile__username"><i class="fas fa-user-circle"></i></a></div>
							
			<!-- Help / Documentation-->
			<div class="l-menu__item"><a href="https://docs.hestiacp.com/" rel="noopener" title="Ayuda" class="l-profile__help" target="_blank"><i class="fas fa-question-circle"></i></a></div>
			
			<!-- Logout -->
							<div class="l-menu__item"><a href="/logout/" title="Salir" class="l-profile__logout"><i class="fas fa-sign-out-alt"></i></a></div>
					</div>
	</div>
</div>

<ul class="notification-container hidden animated fadeIn"></ul>

/var/log/apache2/domains/ or /var/log/nginx/domains will also work

Also try running
nginx -t and apache2ctl configtest

And see if there is any issue

/var/log/apache2/domains/ or /var/log/nginx/domains will also work

yes!!! i see all logs… with apache2 shows the report to website (port 80 or with ssl) and in nginx route show a report of logs of webmail (i don’t know why)

The report of nginx shows nothing apparently unusual

This is one error log (first lines) in one domain who appears in list of apache2 list:

cat mydomain.com.error.log

2021/05/27 01:26:01 [error] 640863#640863: *1002537 connect() failed (111: Connection refused) while connecting to upstream, client: xx.xxx.xxx.xxx, server: ----------.com, request: "POST /wp-admin/admin-ajax.php HTTP/2.0", upstream: "https://xxx.xxx.xxx.xxx:8443/wp-admin/admin-ajax.php", host: "mydomain.com", referrer: "https://mydomain.com/wp-admin/post.php?post=135&action=elem              entor"

in another logs of another domains show other things but the problem affect to all of them and starts with the auto-update of hestiacp.

Then, I tried to do what you suggested, but this was displayed on console:

Last login: Thu May 27 12:03:29 2021 from xx.xxx.xxx.xxx
[email protected]:~$ sudo su
[email protected]:/home/ubuntu# nginx -t y apache2ctl configtest
nginx: invalid option: "y"
[email protected]:/home/ubuntu#

:face_with_hand_over_mouth:

…sorry,

nginx -t

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/ngingx/nginx.conf test is sucessful

and with apache:

apache2ctl configtest
Syntax OK

in HestiaCP, i check to access to all things and seems all be ok, but all pages show error 500 and i can’t to access to phpmyadmin (if i try to open any database from HestiaCP)

Hey,

Had same issue this morning. Just go to any website on the control panel and change the php version and hit save and all the sites will work. Even on different users and then just change it back.

Thanks for your info. I’m sure your solution will help someone.

Unfortunately for me, I’ve tried it and no… still the same.

Any other ideas? :frowning:

*I can access to mariadb when i connect it with console, but i don’t know how can i do backups (because don’t have and with this problem is important to do it)

in the report of error.log of one domain i see some lines like this

2021/05/27 06:21:03 [error] 640863#640863: *1007365 connect() failed (111: Connection refused) while connecting to upstream, client: XX.XXX.45.109, server: c_________o.com, request: “POST /wp-admin/admin-ajax.php HTTP/2.0”, upstream: “https://XXX.XXX.XXX.251:8443/wp-admin/admin-ajax.php”, host: “c_______o.com”, referrer: “https://________.com/wp-admin/post.php?post=78&action=edit”

maybe upstream and host will be the same (…?) posible error?

wouldn’t that be caused by the iptables mentioned in other posts?

Then, I’ve seen that it ‘seems’ that this path (/var/log/apache2/domains/) shows the web logs; while this path (/var/log/nginx/domains) shows the webmail logs.
I don’t know if this last one is important to take into account.

i update all system (apt-get update and apt-get upgrade)

in the process, don’t change the nginx.conf (i press n) and reboot.

-I can access the management panel and everything there is functional.
-I can access the ftp.
-the web pages are still inaccessible with error 500.

This is a long shot, but in your PHP can you check whether you’re using the shorthand PHP opening tag (ie, <% rather than <%php) - I noticed after the upgrade to 1.4.1 that’s now been disabled by default and will give a Error 500 if you try and use it.

If that’s the case, either enable the shorthand in your PHP config, or go through your PHP scripts and make sure you’re not using <%

Pete