Internal Server Error 500

Friends,

I am getting internal server error on my website, I am installing a new script. Error log of the website are showing as follows:

[Sat Mar 23 16:57:48.296280 2024] [core:alert] [pid 920427:tid 281473609351552] [client 10.0.0.132:33266] /home/khaiser/web/ai.domain.com/public_html/.htaccess: Invalid command 'Header', perhaps misspelled or defined by a module not included in the server configuration
[Sat Mar 23 16:58:01.003700 2024] [core:alert] [pid 920427:tid 281473735176576] [client 10.0.0.132:37344] /home/khaiser/web/ai.domain.com/public_html/.htaccess: Invalid command 'Header', perhaps misspelled or defined by a module not included in the server configuration
[Sat Mar 23 17:00:22.832871 2024] [core:alert] [pid 920427:tid 281473760354688] [client 10.0.0.132:59818] /home/khaiser/web/ai.domain.com/public_html/.htaccess: Invalid command 'Header', perhaps misspelled or defined by a module not included in the server configuration
[Sat Mar 23 17:00:23.392977 2024] [core:alert] [pid 920427:tid 281473223483776] [client 10.0.0.132:59830] /home/khaiser/web/ai.domain.com/public_html/.htaccess: Invalid command 'Header', perhaps misspelled or defined by a module not included in the server configuration, referer: https://ai.domain.com/

My .htaccess file is showing the code as below:

<IfModule mod_rewrite.c>
    <IfModule mod_negotiation.c>
        Options -MultiViews -Indexes
    </IfModule>

    RewriteEngine On

    # Handle Authorization Header
    RewriteCond %{HTTP:Authorization} .
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    # Redirect Trailing Slashes If Not A Folder...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} (.+)/$
    RewriteRule ^ %1 [L,R=301]

    # Send Requests To Front Controller...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]
</IfModule>

Header always unset X-Frame-Options

# BEGIN LiteSpeed
# The directives (lines) between "BEGIN LiteSpeed" and "END LiteSpeed" are
# dynamically generated, and should only be modified via WordPress filters.
# Any changes to the directives between these markers will be overwritten.
<IfModule Litespeed>
SetEnv noabort 1
</IfModule>
# END LiteSpeed

# Hide a specific file
<Files .env>
    Order allow,deny
    Deny from all
</Files>

Please try google first: Invalid command 'Header - Google Suche

a2enmod header
service apache2 restart

2 Likes

You must add headers module to apache:

a2enmod headers
systemctl restart apache2
3 Likes

Thanks bro, this solved my problem, my website is working like a charm…