Is this something with Mariadb conf?

This is probablly no Hesita related but need some advise.
I am running nginx core web app - noopcommerce, I am getting at Mariadb logs;

2021-10-29 17:12:02 32 [Warning] Aborted connection 32 to db: ‘dbbame’ user: ‘dbuser’ host: ‘localhost’ (Got an error reading communication packets)

And web app can not run. But if I move db to another mysql db of directadmin server then it runs fine.
I already tried increasing max_allowed_packet but did not work.

I tried all those thing…

Probaly compare both configs could lead you to the missed setting.

I am going to give it once more try.

There are lots of directives. Do you suggest one to check?

no, otherwise I would have suggested it already.

Can I go back to Mysql from Mariadb to test it ?

No, mysql is currently not supported There is a thread here in the forum, where mysql support has been made on a fresh install.

You mean this one: