Issue with Backups

Hello! I encountered such a problem.
Hestia reserves space on the server (inside the tariff plan) for two backups. And I don’t have enough space in the tariff plan to make a backup.
Is it possible to disable this reservation or change the reservation from two to one copy?
Right now I can’t make a backup, and I can’t download files in the file manager. I have 82GB left in my tariff plan, but it’s not enough to make a backup.

Hi @Alex-C,

Hestia checks that you have at least twice the space used by the source and you can modify it to only check that at least there is the same space as the source instead of 2x. This could cause issues and leave your server using 100% of disk so use this at your own risk:

As root execute these commands:

cd /usr/local/hestia/bin/
cp v-backup-user v-backup-user.original
sed -i -E 's/(^let u_disk.*\*\s)2(.*$)/\11\2/' v-backup-user

If you want to restore the original script:

cd /usr/local/hestia/bin/
cp v-backup-user.original v-backup-user
1 Like

@sahsanu, thank you for your response.
You sent me the code, I understand it’s for SSH? I don’t know how to use it, and I don’t even know where to find it. I reached out to the hosting support, but they replied that they don’t provide assistance and I need to hire a system administrator.

Is there a way to change the settings without SSH??

Yes, it is.

Login to your server via ssh and execute commands are basic skills that you should have. Do you have root password or a user that could be able to login to your server?

1 Like

Thank you very much, your advice worked correctly, the code modification part went smoothly. The only thing I changed was the sed command to ‘sed -i ‘s/( $u_disk_original mb * 2 = $u_disk mb)/( $u_disk_original mb * 1 = $u_disk mb)/g’ v-backup-user’, and now the backup was created and I was able to download it.

1 Like

You are welcome.

just for the records, the sed command I provided should work fine, it’s not the first time I use it :wink:

I’m happy to read it :slight_smile:

1 Like