Issue with webmail after vesta import

Hey Folks,

So I’m having an issue. I even saw someone post about the same issue, or similar, but whats happening to me is not the same.

I have been using Vesta for some time and my host just forced a ubuntu distro upgrade. When it did, Vesta went wonky on me. Thats when I learned of Hestia.

So I did what was recommended, and spun up a new server, applied all updates, and installed Hestia. When the install was done, I imported my last backup from Vesta and everything seemed to go smooth.

Except one thing. Webmail. When I try to go to webmail on any webmail domain, I get the default SUCCESS page.

So I googled and searched the forum. I found a post by someone where it said something about web domains. But I dont have webdomains for any of my email domains (except the default domain).

Even tho i dont have any web domains, i tried to follow the directions and run the v-delete-sys-webmail and v-add-sys-webmail scripts (these dont exist anymore, they have a new name), and i located the newly renamed files and tried. I deleted webmail for a new domain I added POST install, then added it.

Same thing. So imported email domains dont work, and new domains I added since the install dont work. They all show me the same SUCCESS page.

Anyone have an idea?

Ok, I MIGHT know whats happening, and Im about to try to fix it manually, but I need to know how to fix it in the interface. Here’s the deal:

In :/home/user/conf/mail/ I have the nginx.conf, and in it, I see this:


(yeah, I changed the listen to a generic name). This was the private network digital ocean now adds to its droplets, and NOT my public ip.


Nothing. There was also an apache2.conf in the same folder with the same wrong ip address. Changing that manually also had no effect, even when trying to connect to

So, thought I had something, and I dont. Still searching for the answer.

Oh, and worth noting that the letsencrypt “acme challenge” also fails, so it looks like its ignoring this whole config in this folder.


Turns out mail isnt processing, since the is also serving up a webpage instead of mail services. So, this is just broken and none of my email for 5 domains are working since the switch from Vesta.

make sure your DNS match your new installation if you merged from vesta to hestia

also, don’t forget to remove old bookmarks with vesta and new bookmark hetia with webmail and etc!

last, check for other solutions where others got help with ssl problems earlier here :slight_smile:

Tell us if this wasn’t what you’re looking for and good luck

Validate which public ip is set as default ip, change it to the public one (it seems you’ve got two), then rebuild the user (v-rebuild-user username) and check again.

“Make sure your DNS match your new installation”

So I checked my installation and INDEED my dns records were set to one of the internal ips. So i changed them and BOOM webmail worked on my new domain. I was able to log in, see a couple of messages.

So I tempted fate to see if I could add SSL (lets encrypt) to the domain. No, didnt work. 404’d on the ‘well known’ url.

And as a result, webmail is broken again. Showing me the same welcome message as it was previously. Checked DNS and the webmail ip was changed back to the internal. So I changed it back to the public one, and it still doesnt work.

So, worth mentioning, the new domain I added POST migration is the one IVe been working on here. It is also one of the only domains with a DNS zone here in hestia. All of my Vesta imports do not have DNS zones here (I maintain their DNS elsewhere).

I was elated when webmail started working, and immediately bummed when it stopped. Ideas?

oke again, check your sys ip…

Plenty but let’s see how admins and team leaders can help first to learn from them :smiley:

I had 1000s of similar cases in Plesk where I was at but let’s see if he tells you google search because he can’t guide you with tutorials as I was told before :wink:

So, in the quest for finding the “default ip”, I ended up inside configuration → network, and found i had 3 ips. One of them had a domain attached, so i went and changed that domain. Once done, i deleted the two local ips in the list. When I hit save, I got an error message that nginx refused to start.

So, back to the command line and ran an nginx -t to check the config. And yeah, it could not bind to the internal ips any longer. As a matter of fact, a quick ifconfig showed me that the ips no longer exist on my server. I mean wow, I did intend to remove them from my config, but not from the server. Dang.

Anyways, nginx still wouldnt start. So i went to the folder /etc/nginx/conf.d/domains/ I see symbolic links to all of my mail domains. ALL of them had the no longer existing local ips in them. So, I used SED to update them all and yes, once again all webmail pages load, but ALL of them are still the Success page. None of them actually show roundcube.

Love to. Can you point me where to find that setting? Id love to verify it.

So I know I didnt say this directly before, so my apologies. I had looked for the default IP, and found multiples and god rid of the two errant ones, before running the v-rebuild-user and then manually fixing the nginx.conf as I posted above.

Hmm. Seems all of the “webmail.domain.tld” are all serving the same page from /var/www/html. Dont know if that helps.

Ok, so I took a step farther. I went ahead and deleted completely the new domain i had added after the vesta import. And then recreated it. It created fine, and the webmail load to roundcube.

So I added a user, sent an email to it, logged into roundcube and boom. Message. A reply sent the message back, to boot. So so far, so good.

So next, I went ahead and added SSL to the mail domain. Boom, worked first shot. I can see the proper SSL configs in the /home/admin/conf/mail/domain.tld folder.

But when trying to use it at https://webmail.domain.tld/ I get the same “Your connection is not private”. And when I check the cert, its pointing to the DEFAULT cert for the default domain for the server.

Still doesnt explain the rest of the domains though. I checked, all of the nginx configs are identical (except for host names) as the new one i just re-added. But they dont work.

Sorry I keep posting and posting, just Im trying to get this all working and keep finding new data that may or may not be relevant.


And add the correct ip address to ip=‘’ and it should work fine

Or just add as web domain

eris, thank you!! I added the IP=‘x.x.x.x’ into the mail file for the mail domain, and SSL worked immediately after a restart of hestia services. Funny, but IP= doesnt exist in that file otherwise. If I change the mail domain, will i need to come in and manually change it again?

Now if someone could solve why none of my imported-from-vestia mail domains do not resolve to roundcube when using webmail.domain.tld or mail.domain.tld, Id be rocking.

(I think ill ignore the 454 tls errors from google for now, and attack that one at a later time)

i would suggest to remove the non existent/private ips from the list after you installed hestia, a restore will then automatically take the “right” ip.

So I should I add a new user, delete the imported user, and then re-import? Or should I do a complete reinstall?

Rebuild will work fine

Rebuild? Is there a way to rebuild Hestia or the user? I cant just rebuild the OS, its digital ocean and Id need to create a whole new droplet and change all my DNS again.