Issues after installing hestiacp on debian 10

On a clean server, after update and upgrade, I downloaded the script and installed hestiacp.

At the time of complition of the installation, some updates were not fetched as follows:
Configuring System IP…
[ * ] Installing remaining software updates…W: Failed to fetch Temporary failure resolving ‘
W: Failed to fetch Temporary failure resolving ‘
W: Failed to fetch Temporary failure resolving ‘

After a reboot, apt update command continuously throws error.
W: Failed to fetch Temporary failure resolving ‘
W: Some index files failed to download. They have been ignored, or old ones used instead.

Any idea how to fix this?

DNS resolution issue, check your nameserver config.

1 Like

I have been reading another thread and its mentioned that it is occuring in OpenVZ.
Also I am able to see some changes in file in hestiacp.

How to compile it and run the pre-release version?

Pre-release version will not help, the latest version has been released today, there is not much new in main branch. You need probaly to find out, where it hangs (I bet on iptables/firewall) or use another virtualization engine like kvm.

1 Like

I re-installed the latest version released 3 hours ago and the same issue occured.
I disabled iptables and it worked!! as you instructed.


Disabling iptables isnt a good idea, you would be without any protection. I strongly suggest to find out why it fails instead “just” disabling it.

1 Like

I disabled and did the update and enabled it again.
Would that be ok?

Yes but it would still not explain why it not working:

Might help…

Just created an OpenVZ VPS and have issue but so far Bind9 is still refusing to work…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.