LE-SSL on Hestia Control Panel

Hello Support,

I just did a new installation of Hestia Cp on my VPS. The domain works fine on LE-SSL

The problem is, I cannot force ssl on Hestia Control Panel.

I did as your document:

(1): run the first command without an error message.

v-change-sys-hostname myhostname.com

(2): the second command, gives error message

v-add-letsencrypt-host

Error: Web domain _______.com exist

Error: web domain www._______ doesn’t exist

The DNS on my VPS is setup fine with both IP and www.

I’m not an expert, can I please get some help and advise ASAP please. I want to launch my site.

What happens if you run

v-list-web-domains admin

If the domain doesn’t exists:

v-add-web-domain admin hostname.com

And then
v-add-letsencrypt-host

When I run:

v-list-web-domains admin

The result is;

DOMAIN IP TPL SSL DISK BW SPND DATE


healthsmartnutra.com 162.216.16.176 default yes 0 0 no 2020-09-09

And your hostname?

Sorry, I’m not an expert. But the Hostname details with command ‘hostnamectl’

[email protected]:~# hostnamectl

Static hostname: www.healthsmartnutra.com
Icon name: computer-vm
Chassis: vm
Machine ID: b657d142fd7147efb2d4201fa3499073
Boot ID: 335c0ee338224e7b8008a60fc2918848
Virtualization: kvm
Operating System: Ubuntu 20.04.1 LTS
Kernel: Linux 5.4.0-47-generic
Architecture: x86-64

That is not a valid hostname.
mytitchybox.healthsmartnutra.com is.
www. is a typical subdomain used pre-2000

1 Like

Hello AlwaysSkint

Thanks for your reply.

I did make changes;

  1. Static hostname: hsnweb.healthsmartnutra.com
  2. DNS record updated on Linode hsnweb =====> 162.216.16.176
  3. Did the commands as ‘root user’ as in Documentation - How to setup Let’s Encrypt for the control panel

v-change-sys-hostname hsnweb.healthsmartnutra.com
v-add-letsencrypt-host

Both the above command this time ‘generated NO-error-messages.’

but…

Problem still exist after refresh the HestiaCP browser login, and still get ssl-browser warning!
Problem still exist after ‘Rebooted Ubuntu 20.04 LTS’

Any help and advice please……………

In addition to above mentioned steps. I also checked again the listing…

v-list-web-domains admin

DOMAIN IP TPL SSL DISK BW SPND DATE


healthsmartnutra.com 162.216.16.176 default yes 1 0 no 2020-09-09

Domain has SSL

Hestia CP Login-panel does not have SSL., what else can I try to fix this?

You have other DNS issues.
http://leafdns.com/index.cgi?testid=5C80A8EF
You don’t need ns2. if you are using Linode as your slave DNS.
Do you have AXFR in place to transfer between Linode and your ns1?
No doubt there are other DNS issues, which need to be resolved before you get a vaild SSL from LE.

Thanks for your reply

[1]. There is no transfer in place. I transferred hosting in 2019. That’s 2-years ago from Siteground to LinodeVPS

[2]. And the domain healthsmartnutra[dot]com is registered with another domain registrar.

After transfer from Siteground to Linode-VPS, I changed DNS to ns1.linode.com and ns2.linode.com on the 'Domain Registrars Dashboard."

There was no problem after moving from Siteground to Linode.
And I always used the 'domain registrar’s free DNS service."

[3]. On Linode, I used Vesta CP without any DNS issue.
VestaCP has security breach warning and.I moved to premium Webuzo-Panel.

There was no DNS issue at all even after when I moved to Webuzo Panel.

[4]. A week ago, everything was working fine with premium Webuzo Panel.
Problem started with Webuzo panel when I received the notification for MySQL 8 unpdate.
I did update inside the Webuzo-Dashboard and WordPress site went down.

[5]. Webuzo reps in India could not assist me. Luck I had a previous backup.

[6]. This week just yesterday, I decided to move over to and install HestiaCP and tryout.
Till last-night and today facing the HestiaCP Login-Panel not able to get LE-ssl.

On VestaCp and Webuzo I used LE-ssl without any issue.

It seems that the issue is with ‘HestiaCP’ and possibly NGINX-SSL on HestiaCP.
The domain has captured LE-ssl fine. But HestiaCP Login-panel has failed.

I live in Australia, and whole of yesterday plus whole of today I have been in search for the solution. Documents did not help.

So I am here on the forum.

1 Like

http://leafdns.com/index.cgi?testid=851CDBA4
Don’t think that you’re really “listening”.
Add an A record at linode for your hostname.

I’ve actually have updated that ‘A record’ today early morning almost almost 10-hours ago.

v-change-hostname hsnweb.healthsmartnutra.com
v-add-web-domain admin hsnweb.healthsmartnutra.com
v-add-letsencrypt-host 

Should do the trick.

Next time make sure you set up the hostname with the correct domain before hand as it would make the setup 10 times easier…

1 Like

Hi Eris,

Thanks for your reply. “Your last sentence is absolutely correct.”

During the initial setup excitement,
I inappropriately set up the; Static hostname: www.healthsmartnutra[dot]com.

Then ‘AlwaysSkint’ in his message pointed this out to me.

Afterwards I tried to set Hostname, and FQDN.
The changes did take effect in Ubuntu: nano /etc/hosts.

However, it seems that HestiaCP NGINX/NGINX-ssl did not like all the mess I made.

What I did was quickly rebuild my Ubuntu 20.04 LTS and then reinstall HestiaCP.

The Panel-Login-ssl works.
The browser is no longer giving me warning.

Thanks to you all and the forum members.

You people do indeed go out of your way to assist.

And you people even give handy clues while suggesting solution.

I will now complete my setup now.

Thanks a million to you all.

I have a ‘quick’ question: When I installed Ubuntu the memory usages was = 3.8%

After installing HestiaCP the memory usage has shot-up to: 39%
And I haven’t even installed WordPress yet!

Is HestiaCP resource hungry?

https://www.linuxatemyram.com/

1 Like

Thanks a lot!

“Hestia” isn’t hungry from ram how ever PHP-FPM and Apache2 are. But it to bad as long the swap get accessed a lot nothing is wrong

1 Like

Ok thanks,

I have NGINX + PHP-FPM (without Apache2).

My VPS plan has a 4GB RAM + 2CPU. It’s for only my own 1 or 2 website hosting.

One thing I did not do is create SWAP file size during Ubuntu 20.04LTS installation.

Should I create manually a SWAP allocation in Ubuntu?

IF SWAP file allocation is required, what would be the recommended SWAP size?

or…

I should not worry about it at all?

Swap space can be though as a “safety net”. In the case a program needs more RAM that what is available, swap will be used as the “safety net”. If swap does not exist, a process will be terminated to free some RAM.

If you can be sure that no program will ever need more RAM than what is available, then you don’t need swap. In any other case you could have some swap, “just in case”. Personally, I wouldn’t go for more than 1GB swap in a well memory sized system. But I’m not an expert on this.

2 Likes

Thanks Felix, I keep and eye on it and see how it goes.