Let's encrypt for mail

Well, there I am again!

Yesterday i moved 2 domains including mail to a new server with hestia. Ofcourse it was for testing parts to see how the backup and migration works.

All went fine, but it doesn’t set the mail SSL good? Is this a known issue or isn’t it an issue!?
When i try to request a new Lets encrypt certificate, it already shows a certificate and i can find one already in the folder: /usr/local/hestia/data/users/DOMAIN/mail/

It just doesn’t load it in?

Now i’ve tried to delete the certificate, and try to request a new one but that just gives me errors that it can’t be empty. and after that it shows a cert again but doens’t load it in.

Is there a way where i can debug it?
This can be found in the hestia error logs:
2020-03-06 09:38:20 v-delete-mail-domain-ssl ‘domain01’ ‘domain.nl’ [Error 3]
2020-03-06 09:38:20 v-delete-letsencrypt-domain ‘domain01’ ‘domain.nl’ ‘’ ‘yes’ [Error 3

The cert isn’t even getting deleted, just stays alive.
Therefore i can’t replace or force new ones?

I’ will check the logs further and try to find anymore information.

If i click SSL.
Remove the let’s encrypt checkered box.

It gives me an error code 3. Thats fine, now it clears the boxes.
When i do it again but now request let’s encrypt it gives me the error that the boxes cant be empty. hmm.

Is there something that it keeps remembering there “was/is” a cert?

Think i found a fix!

When restoring a backup and there is SSL for mail included it seems to set a file wrong?

Inside this file it has set SSL on NO.
While there was a SSL.
After i set it on YES and remove SSL through the interface of hestia.
I was able to request a new let’s encrypt certificate.

E-mail SSL works now again.


DOMAIN='domain.nl' ANTIVIRUS='yes' ANTISPAM='yes' DKIM='yes' SSL='no' LETSENCRYPT='yes' CATCHALL='' ACCOUNTS='1' U_DISK='905' SUSPENDED='no' TIME='13:26:39' DATE='2020-02-19'

After the “fix”

DOMAIN='domain.nl' ANTIVIRUS='yes' ANTISPAM='yes' DKIM='yes' SSL='yes' LETSENCRYPT='yes' CATCHALL='' ACCOUNTS='1' U_DISK='905' SUSPENDED='no' TIME='13:26:39' DATE='2020-02-19'

Notice how it has SSL on NO but let’s encrypt on Yes…

This should also have been fixed in 1.1.0 :).

The new server that runs hestia has 1.1.0. but the backup came from the current release version.

Think the problem was making the backup i suppose or not?