Let's Encrypt validation status 400 after updated hestia

Stopped working some time ago
Error: Let’s Encrypt validation status 400 (drive.mossmp.info). Details: 403:“ Invalid response from http://drive.mossmp.info/.well-known/acme-challenge/Mg5G4xrPQUuP-GTU5OrwKRlA6M-eT8JTCRo5LWYZYvc: 404”
/ nginx -t good .
If i get ssl on another user , Everything is fine . Only on on admin a get this trouble

1 Like

The same thing happened to me, have you found a solution?

I have 2 hestia servers, one in a small test server and another where I have my personal website, my personal website gives the same error when asking for an ssl and the small test server, asks for it well, both servers are exactly the same, the only thing that my personal website is somewhat older (about a year).

The specific error:

Error: Let's Encrypt validation status 400 (trydomain.domain.com). Details: 403: "161.97.XX.XX.XX: Invalid response from http://pruebadominio.dominio.com/.well-known/acme-challenge/6nEQP18ibxX4LCnKa9vhrXNOCb1oEq3koe36hH_ps7Q: 404"

For what it’s worth as a note, I noticed that php8.2 is no longer available on both of my hestia installations, I don’t know if it’s normal or a bug.

Check the contents of:

It should be a string of text

1 Like

Hi Eris, thank you for replying,

I can’t find this file, only index.html and robots.txt (automatically generated by hestia).

[email protected]:/home/dominio.com/web/pruebadominio.dominio.com/public_html# ls -all
total 16
drwxr-x--x 2 dominio.com www-data 4096 Mar 15 12:37 .
dr-xr-x--x 8 dominio.com dominio.com 4096 Mar 15 12:37 ..
-rw-r--r-- 1 dominio.com dominio.com 2909 Mar 15 12:37 index.html
-rw-r--r-- 1 dominio.com dominio.com   66 Mar 15 12:37 robots.txt

Page doesn’t exists on the server. We only load the nginx config to create it…

1 Like

I understand, visiting the url just generated by a form request attempt, the page not found message appears.

Is there anything I can do? I have tried changing the nginx template and php, it still does the same thing.

Check if /home/user/conf/web/domain/nginx.conf_letsecncrypt exists

Also systemctl restart nginx

And check /var/log/nginx/errors.log have seen issue in the past with “to much open files”

1 Like

Hello Eris, you have indeed found the problem, there are these 2 errors:

In the file: /var/log/nginx/errors.log

Line where the text “to much open files” matches:
"/var/log/nginx/domains/webmail.dominio.com.error.log" failed (24: Too many open files)

Line where more SSL error information is given:
2023/03/16 08:27:42 [crit] 58165#58165: *9798 SSL_do_handshake() failed (SSL: error:14201044:SSL routines:tls_choose_sigalg:internal error) while SSL handshaking, client: 89.129.XX.XX, server: 161.97.XX.XX:443

Remaining errors in the LOG file: (the vast majority of errors are as follows)
"/var/cache/nginx/micro/8/82/37e1ee657fd3b7acf9a25718594a828" failed (2: No such file or directory)

What can we do in this type of situation?

1 Like

Is caused by the facts the we delete the cache via deleting the folder then the nginx assumes the files still exists and will recreate it.

1 Like

Indeed, this documentation and edit this file, has been the solution, and the SSL is working again.

The edited file was:


*           soft    nofile          65535
*           hard    nofile          65535

This worked for me, thank you very much @eris .

Is there anything I should be aware of to avoid major conflicts with the nginx cache?