Let'sEncrypt suddenly stopped working on my Hestiacp

Hello, I’m kind of new to hosting setup, specially to HestiaCP.
I’m trying to setup a store, so I need SSL for payment stuff. I installed Let’s encrypt software and HestiaCP on my vps, and it was fine.
I set it up yesterday, and it worked correctly for a while, but today it doesn’t.
The only thing I changed was Hestia panel and SSH ports, but didn’t touch anything related to SSL, as far as I understand. Not even DNS related things.

Thing is, I have 2 domains there, and both have activated SSL and LE on the panel, I can see the certificate, key and related information on the panel, pulled by Hestia, automatically. But when I load my website on a tab, it loads just fine if I use “http://domain.tld”; but if I use “https://domain.tld”, it can’t reach the site.

Could anybody give me a clue about this?

What are the new ports

I hope not 443, 80, 8080 or 8443?

They are 1111 and 2121, not used, as far as I know.

Looks like you have a communication issue on port 443 - I don’t think there is much we can do without debugging directly on your server, but this would be in paid suport section.

Infact you wrote that they worked yesterday perfectly and today not, there must been have changed something that stopped it working. Basic debug steps would be to check and restart related services, checking the log, probaly do a tcpdump to see network activity on port 443 and so on.

If I have installed Let’s Encrypt and got the SSL certificates for the domains outside of the Hestia panel, could it cross in some way with the things done inside the panel.
If I don’t install LE stuff in the server, and I activate support LE option in Hestia, will it work?

Normally yes it should work.

1 Like