Log in to phpmyadmin via the admin panel in 1 click

Good afternoon developers, I remember this item was in trouble that year, well, it was postponed for release and due to difficulties in implementation, will this feature appear in future updates or should it not be expected?. I would also like to know if there will be php compositor support from the panel

If you are talking about phpMyAdmin Single Sign On, then it works fine for me. I have enabled it at Hestia UI Settings > Databases and made sure I followed the docs here PhpMyAdmin Single Sign On — Hestia Control Panel documentation

I meant when you click on the database, it immediately enters it as authorized

Judging by the instructions, I select the API, specify the IP address of my server, and I get Page Not Found when I click on the database entry

Make sure you access Hestia via hostname.domain.com and not over ip

Page Not Found

Tried to disable and display ip, tried to exit via ip+port

Or do you need to enter a password here?

you’ve a proxy redirect to 8083 there, this can’t work because you cant reach phpmyadmin on port 8083. Also do not post hostnames or even full links with one click login creds into the wild…

1 Like

In that case




The have the correct rules to allow for phpmyadmin to remain accessble

According to the configs, everything goes as above, where else can you dig to solve the problem?

Check your error logs of the domain

http://joxi.ru/KAgVW7qU5a5382 - - [14/Mar/2022:22:22:51 +0500] “GET /phpmyadmin//hestia-sso.php?database=admin&user=admin&exp=164754184&hestia_token=$2y$10$/.td8fwbKnWYXZun5IlrckQt8PQytjMiccFau HTTP/2.0” 404 1430 “cp.glonin.kz - login - Панель управления Hestia” “Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/99.0.4844.51 Safari/537.36”

the strange thing is that when you click on the link https://my.domain.kz/phpmyadmin/hestia-sso.php we get 404
although there is a physical file

https://my.domain.kz/phpmyadmin/index.php is served from this directory normally