Mail server cannot access sent/draft/junk because of characters not allowed in mailbox name (.)

Hi, I have imported all my emails from cpanel ( 11GB ) and in the account directories they are separated by periods and prevents mail going to sent box and also open the mail boxes. This is a major issue in my move to hestia ( almost done, this is the last issue ) I had enough problems getting the import script to work for cpanel and don’t want to reimport them all. There also seems to be some with a dash. It’s the period I’m having issue with and getting this
error characters not allowed in mailbox name (.)



Hi @mrea,

Those dovecot files are not related to your issue.

From the same dir you did the ls do:

ls -la
cat subscriptions

And show the output, preferably as text.

Hi @sahsanu Here is the output, looks like the other directories were hidden and have .sent etc I take it this is the issue. Would I have to edit every email account and remove the period or will this break stuff?

Those dirs must have a dot, don’t remove it.

Edit subscriptions file and at the end add directories, Trash, Drafts, Sent and INBOX

V       2


Once done, try again.

1 Like

Hi @sahsanu I just gave that a go but no luck, still get the same error, do I have to restart anything?

Hi @sahsanu I had to remove all my accounts from my email client and add them again. But for some reason there is now 2x spam folders on every account?


How can I remove the second spam folder, the original one no longer contains any content. But the emails are all working again now.

1 Like

There is no need to restart but it won’t hurt.

Did you try to access your email account via webmail or any other mail client?

Check dovecot’s log /var/log/dovecot.log we should get more info about the error.

The user mail account has only letters and digits?

cd to mail user dir and list all dirs, let’s check whether there is something strange.

find . -type d

I posted before read your last post.

Great, good news. You have two spam folders because in Hestia the spam folder used is Spam and seems CPanel used spam folder, just delete spam (lowercase) folder.

You should be able to delete it using your email client.

Awesome all done thanks! I have noticed I have no option to enable spam filter and I did have the option to install it when I installed hestia? Is there away to enable it or reinstall it?

Here are all the options you can use when installing Hestia

But do you mean spamassassin or sieve (this is the mail filter)?. Spamassassin is installed by default so I’ll assume you mean sieve. If that is the case, as root execute this script:


I mean spamassassin, on the control panel it just shows red and if I go into edit mail domain there is no option to enable it? same with virus one, but I only have 1G ram and I think that requires more

Then there isn’t an easy way to install it and include it in Hestia, you should reproduce the same steps that the Hestia’s installer does but there is no direct way to do it. Search this community forum because you are not the first asking for this :wink:

Yes, Clamav will need more than 1GB so forget it :wink:

1 Like