Make hestaicp for showare6 ready?


if i want to install shopware6 i got this error :slight_smile:

f yes you are missing some important server configuration. For security reasons, all accessible files are located in the /public directory of your Shopware installation.

Please configure your web server to root your domain to the /public directory of this installation.

How can i change Hestiacp to automaticly create public folder instead of public_html ?

for all domains which i will to create?

Option 1:

Custom Docroot
Upload public folder to /home/user/web/

And set:

Option 2:

Create a custom template

where i can to the option 1?

Just follow the steps @eris has provided:

i dont find this option like on th screenshot???

if it set it to public i got this error :slight_smile:
Error: Target dir outside of target domain dir

Because you probaly havent created or uploaded the public folder yet, it needs to exists.

well i still got this error : Screenshot by Lightshot

somebody help me maybe?

error from install :

he tell me /var/log and cache are missing or wrong but i created these archives too ?

so where is the problem how to fix?

Did you uploaded the whole source code of shopware to public?

yes why?

the system is telling me that var/log and /var/cache is wrong but wtf?

i got this errror too :slight_smile:

fileinode(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/admin/.composer:/home/admin/web//public_html/:/home/admin/web/ in /home/admin/web/ on line 244

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.