Memcached don't work correctly after update

Hello. After updating HestiaCP to the latest version, my cloud running on nextcloud stopped working (“internal server error”), the reason for this is Memcached not working correctly. NextCloud log:

Summary

{“reqId”:“UcFQzO1wfxKdFewMMJGZ”,“level”:3,“time”:“2021-06-02T20:37:22+00:00”,“remoteAddr”:“193.106.172.122”,“user”:"–",“app”:“core”,“method”:“GET”,“url”:"/",“message”:{“Exception”:“OC\HintException”,“Message”:“Memcache \OC\Memcache\APCu not available for local cache”,“Code”:0,“Trace”:[{“file”:"/home/admin/web/site.com/public_html/lib/private/Server.php",“line”:669,“function”:"__construct",“class”:“OC\Memcache\Factory”,“type”:"->",“args”:[“8dc9a8b023580d90efd87dc6be2cbb63”,{“class”:“OC\Log”},"\OC\Memcache\APCu","\OC\Memcache\Memcached",null]},{“file”:"/home/admin/web/site.com/public_html/3rdparty/pimple/pimple/src/Pimple/Container.php",“line”:118,“function”:“OC\{closure}”,“class”:“OC\Server”,“type”:"->",“args”:["*** sensitive parameters replaced "]},{“file”:"/home/admin/web/site.com/public_html/lib/private/ServerContainer.php",“line”:124,“function”:“offsetGet”,“class”:“Pimple\Container”,“type”:"->",“args”:[“OC\Memcache\Factory”]},{“file”:"/home/admin/web/site.com/public_html/lib/private/Server.php",“line”:1700,“function”:“query”,“class”:“OC\ServerContainer”,“type”:"->",“args”:[“OC\Memcache\Factory”]},{“file”:"/home/admin/web/site.com/public_html/lib/private/Server.php",“line”:633,“function”:“getMemCacheFactory”,“class”:“OC\Server”,“type”:"->",“args”:[]},{“file”:"/home/admin/web/site.com/public_html/3rdparty/pimple/pimple/src/Pimple/Container.php",“line”:118,“function”:“OC\{closure}”,“class”:“OC\Server”,“type”:"->",“args”:[" sensitive parameters replaced "]},{“file”:"/home/admin/web/site.com/public_html/lib/private/ServerContainer.php",“line”:124,“function”:“offsetGet”,“class”:“Pimple\Container”,“type”:"->",“args”:[“OCP\IURLGenerator”]},{“file”:"/home/admin/web/site.com/public_html/lib/private/Server.php",“line”:1673,“function”:“query”,“class”:“OC\ServerContainer”,“type”:"->",“args”:[“OCP\IURLGenerator”]},{“file”:"/home/admin/web/site.com/public_html/lib/private/Server.php",“line”:1148,“function”:“getURLGenerator”,“class”:“OC\Server”,“type”:"->",“args”:[]},{“file”:"/home/admin/web/site.com/public_html/3rdparty/pimple/pimple/src/Pimple/Container.php",“line”:118,“function”:“OC\{closure}”,“class”:“OC\Server”,“type”:"->",“args”:[" sensitive parameters replaced ***"]},{“file”:"/home/admin/web/site.com/public_html/lib/private/ServerContainer.php",“line”:124,“function”:“offsetGet”,“class”:“Pimple\Container”,“type”:"->",“args”:[“OC\Template\JSCombiner”]},{“file”:"/home/admin/web/site.com/public_html/lib/private/TemplateLayout.php",“line”:344,“function”:“query”,“class”:“OC\ServerContainer”,“type”:"->",“args”:[“OC\Template\JSCombiner”]},{“file”:"/home/admin/web/site.com/public_html/lib/private/TemplateLayout.php",“line”:173,“function”:“findJavascriptFiles”,“class”:“OC\TemplateLayout”,“type”:"::",“args”:[[“core/js/dist/main”,“js/merged-template-prepend”,“search/js/search”,“core/l10n/ru”,“search/l10n/ru”,“And 3 more entries, set log level to debug to see all entries”]]},{“file”:"/home/admin/web/site.com/public_html/lib/private/legacy/OC_Template.php",“line”:185,“function”:"__construct",“class”:“OC\TemplateLayout”,“type”:"->",“args”:[“error”,""]},{“file”:"/home/admin/web/site.com/public_html/lib/private/Template/Base.php",“line”:132,“function”:“fetchPage”,“class”:“OC_Template”,“type”:"->",“args”:[]},{“file”:"/home/admin/web/site.com/public_html/lib/private/legacy/OC_Template.php",“line”:334,“function”:“printPage”,“class”:“OC\Template\Base”,“type”:"->",“args”:[]},{“file”:"/home/admin/web/site.com/public_html/index.php",“line”:55,“function”:“printExceptionErrorPage”,“class”:“OC_Template”,“type”:"::",“args”:[{“class”:“OC\HintException”},500]}],“File”:"/home/admin/web/site.com/public_html/lib/private/Memcache/Factory.php",“Line”:98,“Hint”:“Is the matching PHP module installed and enabled?”,“CustomMessage”:"–"},“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0”,“version”:“19.0.12.0”}

I checked that Memcached works with the commands: “systemctl status memcached” and “ps ax | grep memcached”


Everything seems to be fine, but the Memcached test php file and my cloud are not working correctly. When you disable Memcached in the cloud config file, the site starts working again. Any ideas guys.

1 Like

Check if the module is loading in php…

1.4.2 did mainly fix a few bug in Hestia it self and did a quick check regarding Nginx + fix the the bug with iptables…

the question probably is, if OP updated from an older version and therefore more changes occured :wink:

also @Abrikos did you eventually change something in the config files of apache/nginx/php-fpm without creating and using custom templates? then this most likely has been overwritten…

I fix my problem. Installed php modules: php-apcu, php-memcached did not work after upgrade. It was necessary to install these modules for the php versions 7.3 and 7.4 I used, the command looks like this: apt install php7.3-apcu php7.3-memcached php7.4-apcu php7.4-memcached. After that, everything returned to normal. And yes I was upgrading from an older version!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.