Migrating from plesk to HestiaCP

I’m new to this panel and I’m very green on the subject.

I am migrating my server from Plesk to Hestia, everything is fine.
except for how Plesk’s open_basedir deals:
open_basedir: {WEBSPACEROOT}{/}{:}{TMP}{/} (Default)

and now when transferring the first Prestashop domain of 2 that I have.
I get these errors

Warning: file_exists(): open_basedir restriction in effect. File(/views/templates/hook/ht_newsinclude.tpl) is not within the allowed path(s): (/home/pedraja/.composer:/home/pedraja/web/pedraja.com.es/public_html:/home/ pedraja/web/pedraja.com.es/private:/home/pedraja/web/pedraja.com.es/public_shtml:/home/pedraja/tmp:/tmp:/bin:/usr/bin:/usr/local/ bin:/usr/share:/opt) in /home/pedraja/web/pedraja.com.es/public_html/classes/module/Module.php on line 2289

I have copied the php.ini verbatim so that it has the same memory and config. and I’m still the same…

My other question is how do I transfer the 30GB of .netxcloud. any ideas.

Thank you so much

Create a new PHP-FPM template with format like


See: Web Templates and FastCGI/Proxy Cache | Hestia Control Panel

And add :/ to the open base dir value

1 Like

Fixed Prestashop bug, update it

I already have everything solved, thank you very much.

Now I am transferring mail, let’s hope I don’t need any more help, thank you very much.

Maybe this can help if you need to do more then user more …

Requires root admin on the Plesk server

1 Like

@harlek did it work?

No, in the end I did everything by hand.

I uploaded the emails through an imapsync website
taken from this forum.

The Prestashop website is solved by updating.

What happens to me is that this morning I wake up and find this like this.

Check /var/log/hestia/nginx-error.log


“PHP message: PHP Parse error: Unclosed ‘{’ on line 37 in /usr/local/hestia/web/templates/pages/list_web.php on line 346”

I don’t see anything wrong…

We also have not released any update yesterday / today / this week

some command like the one plesk had

plesk repair installation or
plesk repair all


I just realized that I can’t modify anything with the admin user.
I can’t modify anything in nginx or apache from the web.

apt-get install --reinstall hestia

Will reinstall the package…

1 Like

[ * ] Rebuilding user accounts and domains, this may take a few minutes...
      - hestiamail...
      - admin...
      - pedraja...
[ * ] Restarting services...

Upgrade complete! If you encounter any issues or find a bug,
please take a moment to report it to us on GitHub at the UR

and we continue the same!!!

ok reinstall the entire VPS new installation of ubuntu and hestia

How do I use this???

I put .sh??

I don’t think it will help… As it won’t fix any php error codes if the exist…

Do you mind sharing ssh details so I can have a look? (Via DM?)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.