Mobile Phone still showing default page

I’ve been having complaints that my website is still loading the Default Page that says “Your new web server is ready to use.”

I’ve cleared my CloudFlare cache countless times, I’ve checked the WP Installation and there isn’t any cache settings. I even tried doing these that I found in this thread: Nginx cache problem

cd /var/cache/
rm -rf nginx
mkdir nginx
service nginx restart

It still doesn’t work. However if they go to google and click the link from google then it takes them to the page fine. What is going on?

Clear your device cache

I’ve done that, I’ve also tried it on multiple devices and it didn’t work, still showed the same error.

Is there any advice in regards to this?

there is simply not enough information from your side. could be anything.
wild guesses include: issues with the ssl certificate if you use one or none and redirection to that, hsts involved, other dns issues, cloudflare setup, device caches etc.

1 Like

Enable development mode on cloud flare if your are still using the “CDN” options for test sites / testing with javascript / css I often change/add the following

location / {
proxy_pass https://%ip%:%web_ssl_port%;
location ~* ^.+.(%proxy_extentions%)$ {
root %sdocroot%;
access_log /var/log/%web_system%/domains/%domain%.log combined;
access_log /var/log/%web_system%/domains/%domain%.bytes bytes;
add_header Cache-Control no-cache;
expires 1s;
try_files $uri @fallback;

For performance it is a terrible idea but to clear the cache why not