Moved var new partition - no web services?

Hi, noticed the other day space on / was getting low, seems i forgot to create lvm partition for /var

I use hetzner so booted into rescue system, backed up via rsync /var to backup partition, deleted old /var created new var dir, created new partition for var and restored var from backup partition, edited fstab and rebooted.

All files are in new /var

ls -la /var/

total 20
drwxr-xr-x 12 root root 150 Sep 9 13:59 .
drwxr-xr-x 19 root root 4096 Sep 9 14:04 …
drwxr-xr-x 2 root root 4096 Sep 8 06:25 backups
drwxr-xr-x 12 root root 147 Aug 24 20:06 cache
drwxr-xr-x 37 root root 4096 Aug 24 22:23 lib
drwxrwsr-x 2 root staff 6 Apr 10 21:15 local
lrwxrwxrwx 1 root root 9 Aug 15 18:15 lock → /run/lock
drwxr-xr-x 15 root root 4096 Sep 8 00:00 log
drwxrwsr-x 2 root mail 6 Aug 15 18:15 mail
drwxr-xr-x 2 root root 6 Aug 15 18:15 opt
lrwxrwxrwx 1 root root 4 Aug 15 18:15 run → /run
drwxr-xr-x 5 root root 58 Aug 24 20:06 spool
drwxrwxrwt 6 root root 330 Sep 9 14:21 tmp
drwxr-xr-x 4 root root 41 Aug 24 20:07 www

I did apt-get update, apt-get update and nginx needed updating, but this had error messages:

systemctl status nginx.service
● nginx.service - nginx - high performance web server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2021-09-09 14:15:06 BST; 2min 3s ago
Docs: nginx documentation
CPU: 34ms

Sep 09 14:15:06 server.host.com systemd[1]: Starting nginx - high performance web server…
Sep 09 14:15:06 server.host.com nginx[3743]: nginx: [emerg] bind() to 176.9.39.56:80 failed (99: Cannot assign requested addre>
Sep 09 14:15:06 server.host.com systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
Sep 09 14:15:06 server.host.com systemd[1]: nginx.service: Failed with result ‘exit-code’.
Sep 09 14:15:06 server.host.com systemd[1]: Failed to start nginx - high performance web server.

Do i need to reinstall hestiacp?

thanks

ok, access hestiacp via IP address, services currently showing as not started are

apache2
nginx
php.7.4-fpm

they won’t restart?

thanks

this seems to be the issue

nginx: [emerg] bind() to 176.9.39.56:80 failed (99: Cannot assign requested address)

have tried clearing nginx cache, but no joy?

Removed that IP, but error just goes to next IP

nginx -t
nginx: [emerg] bind() to 176.9.39.57:80 failed (99: Cannot assign requested address)

thanks

Do this ips still exists? Never tried to resize lvm with Hetzner …

yes they exist.

Did not resize, just created new lvm with spare space.

also getting

v-update-sys-rrd-nginx
ERROR: /usr/local/hestia/web/rrd/web/nginx.rrd: Function update_pdp_prep, case DST_GAUGE - Cannot convert ‘’ to float

Ok solved, well at least got it working.

For some reason removing additional IPs and re-adding them got things working?

1 Like