Moving from VestaCP to Hestia

Hey,

I have a VestaCP installation and was wondering if there is a easy way to migrate over to HestiaCP.

I just migrated from vestacp. the backup is the same. then just transfer the backup from vestacp and restore on hestiacp.

however, I don’t know if I’m going to stay at the hestiacp. i’ve been using vestacp for years and just migrated because i need IPv6. but now i’ve found that hestiacp doesn’t support IPv6 either.

I’ve been on vesta for years as well, but the lack of security updates. And now exploits posted publicly on their GitHub its time to move. Good to hear that aren’t issue moving over via backup.

IPv6 is on our to do list, but we can’t tell you any delivery date yet.

If you would find any issue, just let us know - we’ll fix them :slight_smile:.

I found that when I restored the Vesta Backup onto the Hestia server, I had to go through all the websites and set the IP address correctly. I felt this was worth mentioning.

One other thing to look out for … in my case I restored the admin user of a Vesta server as another user in Hestia, so that I could switch domains between the users gradually. However this installed the admin crontab as the new user, which gave me some funky errors until I figured out what was happening. Also if you change users, you’ll have to change the DB creds of any websites you have set up from admin_database / admin_dbuser to newuser_database / newuser_dbuser.

Did you had multiple ips on your system? Where exactly you had to change the ip?

This is a correct behaviour, because the cronetab will be imported - you can skip the import of crontab with checking the additional commands of v-restore-user:

[email protected]:~# v-restore-user
Usage: v-restore-user USER BACKUP [WEB] [DNS] [MAIL] [DB] [CRON] [UDIR] [NOTIFY]

So in that way, you could run it with set cron to no:

v-restore-user USER BACKUP yes yes yes yes no

This is also not a bug, just “by design” - this would also happen for additional ftp accounts.

Hi ScIT. Yes, I understand there are ways to avoid getting the results I did. I just thought I’d mention them in this thread in case anyone else ran into them.

I’m trying to remember the exact details of the IP addresses. The server had a private IP (10.x.x.x) as well as a public one. But I think what happened is the website got assigned the wrong one, so I just had to edit each website entry and select the correct one. But it was a while back and I didn’t write down notes, as I usually do, so I can’t say for certain.

I think this may be caused due to that the 10.x ip was set as default - usualy he rewrites the ip properly on restore.

Hi, i have small issue from restore progress…
I tried restore my vestacp backup to hestia:

  1. uploaded backup tar from vesta to hestia backup dir
  2. ssh: v-restore-user username username.2021-02-05_19-10-02.tar

Mail section gives error:
– USER –
2021-02-05 18:56:57 username

-- WEB --
2021-02-05 18:56:58 domain.com
2021-02-05 18:57:06 demo1.domain.com

-- DNS --
2021-02-05 18:58:22 domain.com
2021-02-05 18:58:23 demo1.domain.com

-- MAIL --
2021-02-05 18:58:23 domain.com
Error: /backup/tmp.sGpE4Ixlwe/mail/domain.com/accounts.tar.gz was not extracted
Error: Can't unpack domain.com mail account container

Any tricks to get it work? restore file size is 4gb and it´s not corrupted.

I also tried ssh: mount --bind /backup /mnt/large-partition
Permissions are ok.
System: ubuntu 20.04 and newest hestia

==============
Problem solved:

VPS Memory is running out. would be nice if there is some notice error for that :slight_smile: