Moving hestiacp to new server / new ip address - amazon aws ami

Hello, I moved hestiacp on amazon aws from one aws to another aws using ami replication method.

  1. I am able to open the ip address:8083 url and log into the admin account, i am able to see all my domains listed there.
  2. i have updated the ip address to point to new private and nat address.
  3. when i open my public ip address, it shows a success message with tick mark
  4. i have updated all my dns in cloudflare to point to new ip address
  5. using ftp i am able to veryfiy that all my web files are in their proper folders for each domain.
    i used the below command to rebuild everything
    v-change-sys-ip-nat old ip new ip

when i log into my 8083 admin panel i can see all the domains are pointed to new ip address.

the issue is that the domain is not opening, up until cloudflare i see browser working, cloudflare working, but lastly host error.
It doesnt look like dns propogation error to me.
Please help,

Thank you.

Hi @abeypai,

I’ve never used Hestia in a nated env but regarding v-change-sys-ip-nat command, the arguments are local_ip public_ip, something like this:


Yes i did that. its showing both my private and nated ip according to amazon aws. just the way it was setup according to old server aws configutation

Cloudflare does not listen on TCP 8083.

You will need to use a port that Cloudflare listens on, such as port 2083 that is used by cPanel.

v-change-sys-port 2083

1 Like

I was trying to access the domain on port 80 which was not working.
I Tthink it has something to do with each domain not getting the proper NAT ip assigned because it was cloned from another one.
I ended up reinstalling and, setting up all domains along with setting up all databases again. There weren’t many.
However it would be good for future use, when someone wants to clone the server to another server and ip to have some document on what other configurations need to be changed for domains to work.

For port 8083 management of hestia control panel i was using the direct ip address so that has no effect when using through cloudflare.

Thank you for the help.