Multiple errors after installing Hestia

Multiple errors after installing Hestia.

DigitalOcean Droplet with Ubuntu 20.04.2

The installation was done with the following commands after executing apt-get update and apt-get upgrade

wget https://raw.githubusercontent.com/hestiacp/hestiacp/release/install/hst-install.sh

bash hst-install.sh -f -y not -e mymail.example.com -p myeasypassword -s domain.tld

Domain name registered in ionos DNS configured within DIgitalOCean with webmail.domain.tld and mail.domain.tld pointing to the ip of the “droplet”.

First when I try to enter the panel through https, it sends me a certification error (the same happens with the main domain), I must enter with the ip to access the cpanel.

When I see the “web” section, I find that the IP configured is the internal one of the droplet (I suspect that this could be the error that triggers everything).

Then when adding the mail domain, it allows me to enter through http, but if I add letencrypt it sends me the 404 error message.

I tried to recreate the ssl error, but apparently I already made too many attempts (Error: Let’s Encrypt new auth status 429 (mail.domain.tld)).

Another error or bug is that when I edit the email domain it doesn’t give me the antivirus option.

I add that I do not know if I am configuring something wrong in the droplet because this did not happen to me with gcloud. I hope I can support myself.

Tell me if you need any extra information or a log file, I will gladly provide them.

Note: I add that my native language is Spanish and I am translating this with google, sorry if the text is a little weird.

Thank you in advance for your support.

Your install string isnt valid, it should be “no”, not “not”, aswell as -f should be always be at the end and usualy not be used by default - expect you know what you’re doing. Ah, and domain.tld isnt a valid hostname, this will give you trouble later - use web01.domain.tld or something else.

For Let’s Encrypt 429 and/or 400 use the search form.

1 Like

Thank you very much for answering.
The string does not have “not” it is an error due to the google translation, what catches my attention is “-f” which in the installation page of hestia indicates it right.


But if following your advice I should put the string in the following way:
“bash hst-install.sh -y no -e myuglymail -p myprettypassword -s web01…domain.tld -f”
I reiterate my thanks again.

We will fix the website, I would suggest to just run the install script as written on step 4.

1 Like

Ok I already installed as mentioned.
I already have everything installed,
"Droplet" on DigitalOcean
Ubuntu 20.04.2
dns: cloudflare.
Install with "bash hst-install.sh"
hostname web1.domain.tld

I added a user “user2” to create a web with the domain domain.tld, in this I added the mail, it works very well but through “http”, when I want to add “https” through LetsEncrypt through the hestia panel, the page simply stops working as a 404 error, I currently have “https” disabled to access the mail, but I cannot add “SSL” using “LetsEncrypt”.

There will be some log or something that I can show you to help me solve this error.
I add that I disabled the proxy in each of the cloudflare dns records, in addition, I added the dns: “mail.domain.tld” and “webmail.domain.tld” and pointed them to the ip of the “droplet”.
I have wordpress installed through the option of “install application” within the “web” section.

Anyway, thanks again in advance for your support.

It is a known bug we will patch it this week with a new release

Disable webmail and then enable it will solve the issue

1 Like

Excellent for the patch!!!
Yep, disabling and enabling the webmail solve the problem!!! :raised_hands:t4:
Thank You very much!!! :ok_hand:t4: