My site cannot be reached?!

Hey guys, I am new on hestia.

I just set it up on oracle cloud and was able to add my domain as the panel domain as but when i add the same domain under a new user as the things gets weird.

I have 5 devices with me and some of them open the site directory right away and some of them says “This site cant be reached” . I have tried everything that i could find on this forum and being sure with my ports open etc too but to no chance.

Just now I have also get this kind of weird inconsistency on one pc, regular browser vs incognito tabs.

Weird thing is that if the browser cannot reach the site with “” and when i try to reach the site on that computer as “www.domain.tld” Is takes to “Success” page.

How to fix this?

Any help is appreciated. Thanks in advance.

Sounds like a redirect issue. Just to be sure, what is your DNS provider and are all DNS settings correct?
I would put panel.domain.tld and domain.tld together in the same hestiauser (not in the admin user).

You might want to clear all browser cache / cookies etc. Also, clear DNS cache for your system.

1 Like

For this then, i need to get a new domain that i would only use for the hestia panel… hmmmm Not sure if thats something i want to do…

Funny thing is that, this only happens with that domain. the other ones are stable.

And all the recommendations that you have given, have been tried but didnt help.

Nope, you use panel.domain.tld for your HestiaCP installation. mydomain.tld you can use for something else. They just need to be separate domains in the system and since panel.domain.tld is a subdomain i would put them both in the same hestiauser. As far as I know this is setup like so for security reasons.
If you decide not to do so you might want to try disabling “Enforce subdomain ownership” in Settings - Security - Policies.
Other than that I don’t know what to do…

Thanks for the reply, just to be clear.

You are suggesting me to get my domain.tld and panel.domain.tld to be under one user which is not admin?

Or you are suggesting me to use different domains such as domain1.tld to be a site and panel.domain2.tld to be the hestia panel under admin.

So is it not possible to use domain.tld for both a website and panel’s access domain ?

Yes that’s what I suggest. Don’t put -anything- under admin. The HestiaCP dev-team advices strongly against it because it’s a security risk. Just put them both together in a newly made user with less privileges.

Yes it’s possible. I use host.domain.tld (panel.domain.tld in your case) for my HestiaCP install and domain.tld for nothing. But you could install something there as well. Just make sure that panel.domain.tld and domain.tld are both actual webdomains.

1 Like

I did exactly how you suggested, and my process was removing the website (hcp.domain.tld) from admin side and just adding it back to the user side.

Do you think this would solve it and how long should i be waiting to see that its working?

It should work if your DNS is setup correctly. DNS changes can take up to 48 h in extreme cases. With me it’s mostly maximum a few hours.

There is currently a bug if you have a or it will not add www alias by default

Add it manually

1 Like

Yeah experienced that and added already, thank you ! :slight_smile:

I am afraid there is no change…

The site still doesnt load. And it just did for a second when i used www at the beginning but then it stopped. All the dns records are matching. Checked them on dns checker. There is something within the panel i guess :thinking:

I think it is resolved now.

Reseted the browser, cleared the caches and tried all 5 devices with 4-5 different browsers. It loads like a charm now! Thank you :pray:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.