Need Help with Auto Forwarding Issue


I have a question that’s not directly related to Hestia, but I’m hoping someone can offer advice if they’ve encountered a similar issue.

I’m currently using SMTP2GO as my email relay, and my domain is verified along with DMARC.

I have one email account set to automatically forward emails to an external domain. Recently, the auto-forwarding has stopped working, and anyone who sends an email to this account receives the following error message: “550-From header sender domain not verified (”

The above error occurred when [email protected] sent an email to abc@domain1 which is set to forward emails to xyz@domain2
Domain1 and Domain2 are verified in SMTP2GO, issue happened when forwarding takes place and add the sender domain header. I think if there’s way to keep the header as it is domain1 then it should be fine.

Thanks in advance for any help or insights!

SMTP2GO advised that I will need to change the From address is a verified sender address and that the customer’s email address (e.g. [email protected]) is the Reply-to address.

This would stop emails from being rejected due to the lack of sender verification and allow for any replies to that email to go direct to the person.

Is this doable in EXIM?

Forwarding has long been impractical. If you can configure the ultimate destination to poll a mailbox, that is far more reliable.

Did you include all their DNS records and setup the SMTP user within:

I have one smtp user in SMTP2GO that I use in the SMTP relay settings of the e-mail/domain within HestiaCP.

@Kusto, IF indeed this is your last resort (can not fix anything more in DNS etc.) THEN, ‘this’ can likely be done with exim4 rewrites…
check at the very bottom of the /etc/exim4/exim4.conf.template
you could create a rewrite rule for the incoming (SMTP time) message before it goes back out…
IMHO not the best practice - but I use it to catch incomplete system mails (to me) which exim does not qualify correctly…
don’t forget to reload the template and restart exim after you create the rewrite rule…