Need to send +1000 email per hour

Hi -

How should we configure Exim4 to allow us to send more than 1000 email per hour?

Thanks in advance for your help.

Hi @iramireze,

For authenticated users sending mails via smtp, edit /etc/exim4/limit.conf and replace 200 by the limit you need.

For php scripts, edit /etc/exim4/exim4.conf.template and replace 200 and 100 by the desired limits.

# Limit per user for PHP scripts
acl_not_smtp:
  deny    message       = Website of user $authenticated_id is sending too many emails - rate overlimit = $sender_rate / $sender_rate_period
  ratelimit             = 200 / 1h / $authenticated_id

  warn    ratelimit     = 100 / 1h / strict / $authenticated_id
  log_message           = Sender rate [limitlog]: log / account / $authenticated_id / $sender_rate / $sender_rate_period

Edit mail account or Edit mail account allows you to set the limitations / email account or domain…

Also personally I would always authenticate via smtp

1 Like

Dear @sahsanu -

Thanks for your quick and kind response.

We adjusted both, limit.conf and exim4.conf.template, restarted services and still have the problem with 500 emails. This is the message we are receiving:

Error: SMTP Error: The following recipients failed: XXXXXXXX: Email account YYYYY is sending too many emails - rate overlimit = 200.5 / 1h, e-mail: 0

Can you please advice us?

Thanks in advance

As @eris said, change the limit for the mail user too.

Thank you @sahsanu and @eris -

We are going to adjust the settings and double check…

Regards,