Needs a lot of work

I have used Vesta for some time. I took a look at Hestia becuase of the older versions of software used by Vesta and the difficulty of upgrading PHP versions.

One thing about Vesta is it just worked, it installed clean, fired up, and ran fast. I have not found that to be the case with Hestia.

The install script failed multiple times. I installed on two VPS machines. Both are clean Debian 9 upgrades. One is a test box that is intentionally starved, so I was not surprised when the install hung after saying it would take 15 minutes. After an hour with no lines being output, I quit and reran the script, this time it installed. I logged in using the password I was sent and although the interface is sllllooooooowwwww it did work. I was able to add domains, add databases, and log in to the database one-time using PHPMyAdmin. Subsequent attempts to phpmyadmin were met with adress not found errors.

Second vps - this one not starved at all took several (six I think) attempts. Different points of failure each time . Once got as far into the install as SpamAssassin and failed because that daemon did not start in time Simply put the install script is crap. Yes I could have dug around in config files etc to make everything work but the install should just work better, or at a minimum gie better reasons for failure.

One point that I found funny was the place where it gives a choice to remove the packages that were installed on the previous run Prompt say yes or no yes simply stops the script. Why give a choice?

Finally got the thing installed and received the all done email, bus the password failed. Yes I am sure I had it right I copied right from the email and verified it buy pasting elsewhere, then I typed it. No go. Worse yet I tried so many times I blacked my own access…

Looks like I may have to go back ti Vesta despite the difficulties.

Can you please share more informations about the install string you used? Maybe also about your vps provider. There are no known issues for installation, as example on hetzner cloud or proxmox lxc (ubuntu 18.04 or debian 10) the installation process takes around 3-5 minutes - depends on the load and resources of course.

1 Like

I had no errors with install script except it did not honour the cp port change and desired password, but did find it slow to complete install.

Some minor bugs after though.

Dedicated hetzner server i3770 cpu 32gb ram 2tb raid 1 lvm

Different VPS providers have different OS images, that sometimes can cause issues. Apart from that, VPSes on OpenVZ virtualization often cause issues too.

As for VPS specs, to install certain software there are requirements of course. For example ClamAV will not work on a 1GB RAM VPS (installation might fail too, but I’m not sure). That’s why @ScIT asked for the -super useful information- about the install string used to install Hestia.

To sum this up: One size doesn’t fit all :frowning:

If you’d like to have another go on Hestia, you’ll need to share specs (RAM, Swap, Cores, available space, if it’s HDD or SSD, type of virtualization, provider/product, etc) information that will help us understand what you’re dealing with, so we’ll be able to guide you better :slight_smile:

2 Likes

As far as I know you installed it using multiphp switch, this will install all versions from 5.6 up to 7.3 - this will take for sure additional time :slight_smile:.

In most cases I used the default install. In the one case that ended succseffully I did use the multi php install. Yes that slowed things down but the ooutput to screen indicated that things were moving along so that was okay. Slow install does not bother me as long as thee is indicatoin of progress.

The machine that ended up working after two tries is a 2 virtual cpu and 2 GB ram open vz machine from psk hosting. I say this one worked becuase the install eventually completed and I was able to log in without issues. It was slow but that was expected. As mentioned I was able to add domains and databases on that install.

The multi install of php worked (as in it installed multiple versions) but I was not given a choice at domain setup of which version. It chose the latest 7.4 which would normally be fine but it is odd that no choice was requested. I was able to edit the domain and choose php version. Unfortunatley php did not seem to work on any of the versions. I got the php white screen of death on a phpinfo(); call (and then after some work oddly I got a page not found error). I was able to solve this by making changes in the config per domain.

For the Second machine which took multiple installs I also used the default install. This VM is also open vz same host but had 4 virtual cpu and 4 GB ram. This is the one that failed at different poinst each time. and eventually installed but then the password did not work I was able to get around that using he command line method of changing pasword.

The most common symptom is that the install hangs after the point when it outputs a message about it taking 15 minutes. In one case I waited at this point for 30 minutes before I opened another SSH session and ran top wondering if it ws running and just not echoing . There was no activity on the CPU so I I hit ctrl-c.

One thing that might be of note, The most recent Debian offered by the host is Jessy, I had upgraded both of them (and one other) to Stretch just before the install. After the I did and apt update and apt upgrade and apt -dist-upgrade and installed curl. So these were clean VMs

For not I have moved on and installed vesta on both machines. Both are humming along fine for now. I will deal with the pain of upgrading DB engine and php.

I look forward to trying Hestia again at some point, maybe I willtry it on my local box for grins, but for now I needed to get these machines deployed and could not spend time debugging after spening all day trying to get this installed.

Thanks for your detailed report!

Basicly the multiphp switch “just” adds more php packages and a few templates, basicly this should not let the system hang but will take more time for sure.

As @Felix wrote, does hestia have some problems with OpenVZ (mostly on network side), I would suggest to use kvm based hosters. Also I tried to find out where pskhosting is located, but I wasnt able to find any address or contact informations showing anything usefull. What I can suggest is Hetzner, if you search a europe based hoster.

That also doesnt sound good at all, in the current stack mostly you don’t need the multiphp flag anymore. You can just enable and disable the requested php versions from backend, here a screenshot of this function from our demo:
image

Was this on the same hoster?

This sounds like your hoster isnt verry active, the current and also from Hestia supported release is 10 aka Buster.

That I can completly understand. What I would suggest: Use a local machine with Debian 10 Buster ISO or another Hoster that provides kvm based hosting which is the current state of the art - this has to work flawless, fast and without any troubles. In any cases, let us know how it works!

supposed to be Los Angeles. supposed to be one of most bottom of the barrel provider out there.
there are lengthy threads about it and its probable relationship to the former alpharacks scam operation on reddit, wht and let… I’d rather run as far away as I can.

however, I have no direct experience, just saying that I wouldn’t be surprised if they still run OVZ6 with a 2.6 kernel. I would not try to run more uptodate software on that. rather stick with vesta then. nuff said.

1 Like

That’s what I thought as I saw the hidden whois informations. Thanks for the clarification!

They are out of LA . I have machines running really high end apps that run just fine and others that are crap so a mixed bag overall. The point here is that you are shooting the messenger. If my complaint was that things jsut ran slow then you might be on to something. What I had hoped to do was help troubleshoot what I see as a very flawed installation script.

I’ll not bother further.

We do not shoot the messenger at all, you missunderstood that completly :smiley:.

We just inform that this is probaly not an issue with the installer, more with old OpenVZ virtualization combined with old and manualy upgraded debian images. Please check on another, non openvz provider with current os images and you’ll see that all is working properly.

Personaly, I also dont think this is a stable testing environment.

1 Like

@montanapcdoc - Welcome to the community!

Personally speaking - never had a single issue with Hestia CP.

If you wanna give Hestia CP a shot, please carefully follow step-by-step provided recommendations.

Hestia CP community & support is really exceptional. I’m one hundred percent sure that no one wanted to insult you here in any way.

Let us know whether all works fine once you manage to fulfill the “prerequisites”.

I was not insulted. I have however come the point in life where I recognize when and where my input is appreciated and when and where it is not. It is clearly not needed here and so I will go lay by my dish.

Before I do perhaps I could learn what step by step provided reccomendations you are talking about?

No idea how you came to this point, the only thing we wrote is, that the issue is probaly your hoster, which is using outdated openvz combined with old os images (and hell bad rating in combination with accusations of data missuse if you google him). The only thing I request you all the time, is to use a new and fresh kvm based install of a up to date system like debian 10 (aka Buster) and test the installation again. You’ll see that it works smoothly and without any troubles at all.

3 Likes

In fact it did not.

Running on a 4 GB 4 core KVM Deb 10.

Fourth time is the charm.

Call me bullheaded but i had to keep trying I was finally able to get it it install.

rebooting now to see if it works as expected.

Maybe you can share with us, what you changed to your system that the installer worked? I don’t think that retry the installation 4 times with same settings would be the way to go :smiley:.

Yeah most people would have given up. I’m like a chicken on a bug sometimes. Don’t know that I can retrace my steps exactly due to some fustration.

The install string didn’t change very much between installs excpet on the last one (I willexplain why that changed in a bit) the defaul settings are pretty much okay with me except a couple things

the install string I ended up with is bash hst-install.sh -n yes -w yes -j yes -v no -g yes -s oneofmydomeas.com -e [email protected] -p [passwordwashere]

I ran the script on a 4 core 4 GB ram KVM with a fresh deb 10 install only apt update and apt upgrade prededed the script download and install

First run onthis equipment bailed when nginx would not start

Second run dpkg errros during script - these were left over form the failed install so I cleaned those up, rebooted and tried again

Third run installed mostly but the php did not work again.

Fourth run I reimaged the machine and again did only apt update and apt upgrade

This time the script finally ran smootly. The only change I made to the install was that I left apache off. This latter choice had to do with my discoveries regarding php and how you set it up. I prefer to use nginx with a php-fpm backend most of the time (especially for WordPress) but I sometimes want Apache. When the Hestia script installs Apache and php-fpm it sets things up to have apache provide the backend for nginx and the fpm service provides php support for apache. Although i have used this setup elsewhere it does not seem to work in this case.

So in the end when i let apache of the script installed php 7.3-fpm as a backend for nginx and that all works. Panel is ber fast. I have not been successful at getting the mail portion working yet though.

I do need want apache s well in a gew caases so I wil install that seperatly and hope it doesn’t gum up the works. This means I will have to manally all it as a backend but that is somewhat trivial in the scheme of things

Perhaps you could offer some tips where to look in order to get my mail server sending via a smart host

I dug around in the forums and foud some reference to a sectio of the exim configuration that is commented out, but making changes in that area only caused and error and the log file reverted.

I also tried configuring exim from outside of hestia but that seems to be ignored?

I have a smart host set up which i use daily on other servers. I was fially able to get mail to receive after some erros but wil not send at all

Hi @montanapcdoc

Without any logs, it’s hard to say what is wrong. Exim usualy should work out of the box for send- and receiving e-mails without any additional tweaks (expect you’ve opened all needed ports of course).

I would suggest, that you open a new thread for your mail issues and post in all relevant informations and log files or error messages.