New ADD DOMAIN -Error: DNS record for domain.com doesn't exist

Ubuntu 20.04
Hestia v1.6.10
Adding new domain OK
But while we add LetsEncrypt - shows DNS error
Error: DNS record for domain.com doesn’t exist

  • manually created DNS zone for DOMAIN.COM - but still LE error
  • tried via 'v-add-letsencrypt-domain MyUserName DOMAIN.com

Please have a look at the search function before you open a thread, nslookup domain.tld fails on your server.

I had the same error yesterday.

You need to restart bind.

There is maybe an intermittent bug.

Most times it updates sometimes it doesn’t. Don’t know why. When It doesn’t, I restart bind.

Hestia with installed Bind doesnt automatically lookup over it expect you really have configured it manualy, otherwise it will take the default system dns servers configured in resolve.conf (or resolver.conf, on mobile rn).

@ScIT

Hi team,
Im using this HestiaCP for few years.
Once a existing function working well & suddenly is dropped on immediately-on-after auto updates of HestiaCP, will i search & edit my DNS configs .? OR will i raise ticket.?

Now, the backend tasks are most painful for you team. May be thatswhy your recent replies are so awesome like CPanel support. Haha…

@jlguerrero
Sorry bro. Is not working…
All my existing ~15 domains inside the same user working as usual.
Just adding new domain today, got DNS Errors.
I restarted Apache/Bind9, even rebooted whole server. Still same.
I deleted Web/DNS for that domain & recreated with DNS zone enabled, still DNS not Exists Err. But DNS is created as usual.

The error you posted is clearly related to nslookup fails, that’s why i wrote it.

I dont know your dns setup and you also have not mentioned, that your dns is failing :man_shrugging:. You probaly need to have a look at your bind9 error log to see what fails…

By the way: at least cpanel gets paid for their product… Its really hard to provide that less informations, basicly with just the default error message - so you’ll get the default answer what you’ve to search for. Also we do not provide any support over mail or ticketing.

We have not changed DNS / Letsencrypt in the last few months for the exception of some output improvements:

We run:

So run nslookup domain.com on your server via command line and see if there is any error. You can continue blaming us but I regularly check via our automated testing setup and my self via the panel / command line.

As we have over more then 30k users a function that is key for everybody should tract more user errors.

1 Like

@ScIT
OK, i follow your instructions to check my BIND9 err logs.

By the way: I mentioned that 3rd party support team, not to discourage your ability. You are better then others in my openion of past 7yrs of lookup for panels. I meant, that support team’s support is so lagging on most cases. Lot of bad reviews about their support, but product is stronger. We leave about that matter. :slight_smile:

[email protected]:~# nslookup NewDomain.com
Server: 8.8.8.8
Address: 8.8.8.8#53

Non-authoritative answer:
Name: NewDomain.com
Address: 123.123.123.123 (MyPanelIP)

trigger on your Hestia server.

mm. While i trigger LE it shows DNS not exists. But i could see the related DNS in my DNS tab.
Im not using any CDNs. No CFlare. :slight_smile:

also, If i trigger the LE for old existing domain, it works as usual.

Any aliases used

@eris - Default Aliases
@ScIT - It works now.
@jlguerrero - Thank you

thank you guys.
i suspect BIND9 restart matters. But cant realize where the issue is…

  • I created NewDomain & LE DNS errors…
  • BIND9 restart & server Reboot (Still same)
  • I deleted NewDomain
  • I manually deleted /home/USER/conf/web/Newdomain.com (WEB & DNS)
  • BIND9 restart & server Reboot
  • Recreated the same domain & LE works now.

still strongly suggest to review your bind9 config, probaly zone didnt got loaded.

I found out that my slave DNS in the cluster hadn’t updated some records.

Maybe there is more to it than we imagine.

Its a cronjob that runs every 5 minutes

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.