Newly added domain website SolarGeo.Net is not accessible

My server is running Debian 9 and newest version of Hestia. I had no problem creating domain websites on it before until last night when I tried to set up on it. It gives me the nameserver not resolved error.

Nothing has changed and don’t know why this has happened. I have more than 50 domains on the server and none of them has this problem. Only this new domain added has this problem.

Check you domain nameservers, two of them are not resolving the domain

whois | grep -i "name server"

After you set the correct nameservers DNS propagation will take around 24h, you can check here:

Thank you Lupu for your quick response on this.

I just removed the two nameservers and see what this will do.

But that was the problem I started with :frowning:

I used and (as all other 50’s or so websites use) at the registrar almost two months ago when I first registered the domain. I thought two months were long enough, so I expected to see the domain immediately available when I added it to the server. I included ``` and (given by Hostwinds) only after I found out the domain was not accessible that way.

Somehow, I suspect that it is the bind9 DNS Server setting within my HestiaCP install - it worked before but somehow not for this new domain only.

Bind is responding correct for that domain, but is also including the other two nameservers in the authority list, you need to fix that too.

$ dig

; <<>> DiG 9.11.3-1ubuntu1.10-Ubuntu <<>>
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25454
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 3
;; WARNING: recursion requested but not available

; EDNS: version: 0, flags:; udp: 4096
;                  IN      A

;; ANSWER SECTION:           14400   IN      A

;; AUTHORITY SECTION:           14400   IN      NS           14400   IN      NS           14400   IN      NS           14400   IN      NS

;; ADDITIONAL SECTION:  14400   IN      A  14400   IN      A

;; Query time: 163 msec
;; WHEN: Sun Nov 17 22:24:13 EET 2019
;; MSG SIZE  rcvd: 194

OK, I have removed everything (including DNS and Mail parts) and re-created the domain site at my HestiaCP with DNS and Mail services. This time the server side does not include the other two nameservers. As for the domain registrar side, I removed the other two nameservers yesterday.

Still I cannot access the site - I will wait a bit more and see.

Sound strange. I did all this right in the beginning and it did not work. Will see this time. I don’t think it will work this time.

Indeed there is something wrong, I would recommend you to get in touch with your registrar, the NS records should have been updated by now on the (.net) gtld dns servers.
dig NS @ +trace

On the Hestia side it seems to be nothing wrong, bind9 is responding as it should.

Got it!

After contacting my domain registrar, I found out that I needed to receive a domain whois activation link, I forgot about that part. My computer’s hard drive was damaged by a power outage and I have not set up a few email accounts on my Thunderbird email client.

I accessed the email via browser and clicked the activation link. That should solve the problem.

Thanks so much!

1 Like