Nextcloud instance "Not secure"

I created a subdomain website and enabled ssl. Created A record to point subdomain to my ipv4 address. Nextcloud install was successful. But subdomain page/Login page shows “Not secure”… Did I missed any step?
Thanks for help

hi @kennchin - you probably want to check in the admin area of nextcloud what domain it is set too and if you want it to redirect from http to https automatically etc.

with that said, the browser also might display a warning if some ressources on the page like external script or images might be on http instead of https (mixed content). so if you use something that display a cookie warning or tracking codes etc. make sure these ressources are all using https properly.

also keep in mind, that if you tried to load it before in the same browser/tab and only then switched to a valid ssl cert, the browser still might show a warning until you competely close and reopen it.

the error message/warning should have more details about that anyway, so you probably want to read it once more :wink:

So far I can remember we do set the correct domain in the settings:

Are you usinng www.sub.domain.com instead of sub.domain.com instead?

I’m using sub.domain.com format

‘trusted_domains’ =>
array (
0 => ‘localhost’,
2 => ‘sub.domain.com’,
‘138.141.184.240’,
‘[2502:ff36:4:0:1:df:0:3]’
),

Is the above correct syntax in the config file?

Manage to make it work, by “Enable automatic HTTPS redirection”
Thanks everyone.

error5

1 Like