Nextcloud issue [UNSOLVED]?

Just installed hestia… tried to set up nextcloud but looks like some php7.4-packeages aren’t installed.

I tried to installed using terminal
apt install php-packages (Ubuntu 20.04)
But seems like it will install php7.2, instead of 7.4 which I use with hestiacp.

So what to do? Add a repository with php.7.4 or those packages can be installed thru hestiacp?

Thank you

And the nextcloud says… How to fix it?

Internal server error

The request could not be processed by the server.
If this happens again, send the detailed message below to the server administrator.
See the server log for details.

Technical details

Nah I’m tried. Once again I tried hestia and nothing has changed. There’s still no nextcloud template, there’s still no easy way to install nextcloud.

Download nextcloud to /home/me/web/, unzipped and faced the issue about. Tried to google but there’s nothing that matches. How many years should I wait unill the product will be fully ready for using?

This is a mockery of common sense

Hey man, you’re free to have your own opinion but it’s really unfair to assume that Hesta should do every random thing you want to do out of the box.

Hestia is a starting place, not a one size fits all solution. There are provisions made available for you to build your own template for nextcloud in which you could then be a useful member of society and contribute it back to the project.

For that matter, there is already an owncloud template available which should be a pretty good starting place. Nextcloud also has very detailed documentation on how to setup apache and nginx.

If you want someone to spoon feed you, you should consider paying for a caretaker (developer).

Have a nice day.


Funny thing but it was cause of rights. I set 0777 for each folder in /public_html and www-data user and now it’s working. But how did I know? It should work out of box, so simple things like nextcloud.

I agree with @cmstew and if you just set 777 permission for the whole public directory let me say that you need to understand before how it works. Saying that, I installed on Hestia 1.3 a nextcloud instance and was a no brained, 2 minutes of autoinstaller and was up. So exactly what you are saying is not. :slight_smile: Good luck with your 777 environment.

At least it works now. What else I had to do? There’s no guide, no understanding how to make nc working. I found this way, even tho it may not be the best one.

@Ubi but if you have a better idea just tell me

I guess my problme is user things. Cause I download nextcloud using wget and root user. But then I changed all the rights to admin:admin… Maybe I should use FTP account who knows…

Yes maybe that is very smart…

  1. Have installed time multiple Nextcloud Instance on both Apache2 and Nginx and it worked with out any issues.
  2. Downloading it via root and chown admin:admin / chmod 0777 is asking for a security risk

If an hacker is able to login onto the server via ssh as admin user. Due to a leak in Nexcloud is able to take over the whole server. As admin user is also the sudo user for the control pannel.

This message has not been create for no reason.

Also “Hestia team members” are not getting paid to do any development work and creating templates they don’t use does not have a lot of priority.

Also there are multiple topics available regarding Next cloud and templates used.


How did you download the nextcloud folder on the server? Using FTP? I prefer wget from the root account, cause FTP is too slow.

About admin I know. I also created a user, but faced the same issue.

of course wget, unpack it and set the right ownership (user:www-data for public_html, user:user for all its content), there is no need to transmitt it over ftp.

Done but after installing nextcloud I got this.

Page Not Found

Oops! We couldn’t find the page that you’re looking for.
Please check the address and try again.

So next time I tried to use user ssh account maybe it helps

Nah even using admin account thru ssh I faced this issue with nextcloud

Internal server error

The request could not be processed by the server.
If this happens again, send the detailed message below to the server administrator.
See the server log for details.

Technical details

I’m out guys thanks but I’m out
Tired of the mockery of common sense
Only after all of this it started working lol

chown -R user:user /home/user/web/domain.tld/public_html
chown user:www-data /home/user/web/domain.tld/public_html

Two lines are easier than a lot :slight_smile:. Still the warning: Don’t run it in admin user!

1 Like

8 posts were merged into an existing topic: Nextcloud multiple servers?