Nginx document root and Symlinks

I just set up atomic deploys inside my /home/user/web/{releases, shared,current} folder.

Unfortunately, when I set a custom document root in Hestia CP like ‘/home/user/web/’ Hestia seems to resolve it to its real path. So the nginx conf for that domain reads root /home/user/web/
How can I trick Hestia into accepting the symlink, namely current instead of releases/DATE?

(Especially when there’s a DO NOT EDIT THIS FILE note at the very beginning… ) :expressionless:

v-rebuild-web-domain user domain on update does it work?

Not sure with store the result in the web.conf or not

Easiest method is create a new templates that set the url to

And %docroot% for non html :slight_smile:

I appreciate the instant feedback. The v-rebuild-web-domain command didn’t do much, but maybe I did not have the correct settings in the admin panel for that?!

The custom template with a %sdocroot%/current/public did the trick. I removed the custom docroot in the admin cp and switched to my custom template and bo0oM.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.