NGINX - HSTS not working with FASTCGI cache enabled

Hi, nginx.hsts.conf or my custom security-headers.conf includes are not working when Fast CGI Cache is enabled. Purging the NGINX cache doesn’t help.

You seem to have a point:

Found the issue in v-add-fastcgi-cache the add_header “X-Status hit/miss” was always loaded even when when the debug mode was disabled.

1 Like

Thanks for taking a look at this :slight_smile: Is it something I can fix, or will it be sorted in the next release?

It will be “fixed” in next release.