No exceptions are created category for backup

Hi, on my hestia v1.8.7. I add folders for exclusion when creating a backup according to the documentation:
But after creating a backup, the contents of the folder: public_html/image/cache are still inside the created archive.
If I want to add several folders to the exceptions in the documentation they are separated by “:”, but when saving “:” is replaced by “,”

Are you sure the contents of those dirs are in the backup? I mean, v-backup-user command uses this to exclude directories --exclude=$xpath/* where $xpath is the directory you are excluding like public_html/cache --exclude=public_html/cache/* so you should have the dir but not the files/dirs inside it in the backup. Double check it just in case.

Keep using : I assume that the comma is simply to make it read better in the web interface. If you check the backup-exclusions.conf file, you will see that it is using :

cat /usr/local/hestia/data/users/YOUR_USER/backup-excludes.conf

1 Like

Yes, you are right, the symbols “,” are displayed when viewing the saved exception settings, and inside: /usr/local/hestia/data/users/YOUR_USER/backup-excludes.conf
are displayed correctly, but if you go to the settings in the panel, there will be “,” and if you do not replace these characters, they are so and be preserved.
Next, I tried creating a backup copy of only one folder, tried the following various options with the full path and as indicated in the documentation, but the panel did not make an exception when creating a resevr copy:

2023-09-15 12:45:53 excluding file
2023-09-15 13:00:39 excluding directory /home/user/web/
2023-09-15 13:05:34 excluding file
2023-09-15 13:10:38 excluding file
2023-09-15 13:15:34 excluding file
2023-09-15 13:20:35 excluding file

To test it, I’ve created three dirs with three files inside public_html dir and added these exclusions:


# mkdir /home/user/web/test.example.tld/public_html/{test_dir1,test_dir2,test_dir3}
# echo file1 > /home/user/web/test.example.tld/public_html/test_dir1/file1
# echo file2 > /home/user/web/test.example.tld/public_html/test_dir2/file2
# echo file3 > /home/user/web/test.example.tld/public_html/test_dir3/file3
# chown -R user:user /home/user/web/test.example.tld/public_html/{test_dir1,test_dir2,test_dir3}

# ls -lR /home/user/web/test.example.tld/public_html/
total 20
-rw-r--r-- 1 user user 2564 sep 15 16:40 index.html
-rw-r--r-- 1 user user   66 sep 15 16:40 robots.txt
drwxr-xr-x 2 user user 4096 sep 15 16:42 test_dir1/
drwxr-xr-x 2 user user 4096 sep 15 16:42 test_dir2/
drwxr-xr-x 2 user user 4096 sep 15 16:43 test_dir3/

total 4
-rw-r--r-- 1 user user 6 sep 15 16:42 file1

total 4
-rw-r--r-- 1 user user 6 sep 15 16:42 file2

total 4
-rw-r--r-- 1 user user 6 sep 15 16:43 file3

I’ve forced a backup and untar it.

cd /backup/
mkdir user
tar xf user.2023-09-15_17-10-01.tar -C user

I’ve checked the file domain_data.tar.zst and neither file1, file3 nor robots.txt files are in the backup so, exclusions worked fine.

# tar tvf user/web/test.example.tld/domain_data.tar.zst | grep -E '(test_dir|robots)' | sort
drwxr-xr-x user/user         0 2023-09-15 16:42 public_html/test_dir1/
drwxr-xr-x user/user         0 2023-09-15 16:42 public_html/test_dir2/
drwxr-xr-x user/user         0 2023-09-15 16:43 public_html/test_dir3/
-rw-r--r-- user/user         6 2023-09-15 16:42 public_html/test_dir2/file2 


I found the reason :innocent:I inserted the list for exceptions into the USER section, not the WEB

1 Like