No language defined

I enabled the PHP 7.4 from the server settings and I was logged out. Now it won’t let me login and showing NO LANGUAGE DEFINED error. I am trying to login via the HTTPS link.

Probaly your disk is full, please use ssh and check it.

That is correct. But why is it using so much storage? It is using like 5GB of storage without having any other data.

Depends on what you all have installed, how many php versions and so on. That’s not a question that can be answered just out of the box.

I only have PHP 7.4 & the default PHP version only. Other than that it’s a fresh install of HestiaCP with default installation.

So you also got mysql/mariadb, full mail stack and so on, hestia ships a lot in default and it sounds that you have got a small disk in your vps. Personaly I don’t think 5GB usage as base for so much software you got isnt that big, maybe there is also some swap or other files playing with.

Honestly I didnt had a look how much disk is used after a fresh install yet, will have my eyes open on the next round :slight_smile:.

I have 9.8GB disk on the VPS. Anyways, That was eye opening to know hestia with other things by default.

You can adjust all you want to install or not want:

A typical HestiaCP webstack on Debian/Ubuntu will be around 6.5 - 7 GB in size.
After that it depends on size of sites/apps you host on it and mind that there as AUTOBACKUP routine set for everyday by default which will backup all your hosted sites daily and retain 1 set in /backup.
Lets say you have a 1 GB site hosted, next day 1GB backup set will be created and your 9.8GB disk will be near full.
You can disable backup script if it is an experimental / testing server, however, you should atleast have a 20GB storage drive to start with comfortably.