No rate limits - Error: Let's Encrypt acc registration failed

So i’m researching this issue but there doesn’t seem to be a resolution. Other posts say the error with the LetsEncrypt SSL cert in the HestiaCP is LetsEncrypt rate limiting the server/host IP.

I’m only adding one site. I tried last night it failed, tried again this morning and same error. Attempted to add the SSL both from the Hestia control panel and from the command line. Any ideas?

Error I’m receiving:

Error: Let’s Encrypt acc registration failed

For all commands, replace HereYourUser by the actual user.

Your user has a valid email?

v-list-user HereYourUser json | jq -r '.[].CONTACT'

Is le.conf file created for your user?

ls -lh /usr/local/hestia/data/users/HereYourUser/ssl/le.conf
1 Like

Looks like the le.conf does not exist in my user’s directory. How do I get this generated?

It’s ok if it is not generated as you didn’t register the account with Let’s Encrypt, I just wanna know whether the file was there.

What about the other question?

Also, what is the Hestia version you are using?

1 Like

I think i see the issue now. DNS isn’t resolving properly. Attempted to fix it but still not working so I’m re-imaging the server. Should hopefully fix it. Thank you!

1 Like

Odd, so i reimaged the server, confirmed I could ping DNS was working etc. I installed HestiaCP which required me to reboot. After reboot DNS stopped working again.

cat /etc/resolv.conf

Ubuntu version:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.4 LTS
Release: 22.04
Codename: jammy

added those name servers just in case, rebooted, and still no DNS. It’s odd because I’ve installed HestiaCP on numerous other Ubuntu 22 VPS servers and never had this issue. Could it be an issue with my host/the image they’re using for Ubuntu? I’m lost at this point.

Pinging IP addresses is no issue.

Try: and instead

That’s actually what I’m using currently. Same outcome, unfortunately.

cat /etc/resolv.conf

It has to be something with the image they’re using. I’m going to request to have Ubuntu 20 installed and if that doesn’t work I’m moving to a new VPS provider lol…

maybe they use openvz, there are some known issues with it. Maybe you can use v-stop-firewall and check if you can ping again.

Also if your provider doesnt provide up to date images, its maybe a good idea to move on.

1 Like

LOL that worked! Appreciate the help. That was too simple lol

that doesnt solve your issue, just stops the firewall until a reboot. So probaly openvz, i would suggest to change the provider. is a well loved alternative.

Right, that’s what I thought but I rebooted and it seems to be functioning correctly. Let’s Encrypt is working as well after reboot. Hetzner is great, I do use them for one of my hosts currently, but I’m trying to spread out my infrastructure to different hosts. I might move to AWS if I continue having issues with this host.

Appreciate all the help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.