Not receiving mails from google only

Hello people,

Since last week my server is experiencing some weird problem: Emails hosted on hestiacp won’t receive google mails. That’s it.
It can receive mails from professional accounts and also from hotmail, but not from gmail.

I was trying to find the messages in the logs, but they don’t even appear in the logs (or maybe I didn’t look up the right logs).

Found this fix:


But didn’t help at all.

If I think of a change made in the last month it was updating the SSL cert from withing the console when self-signatured ssl cert didn’t work for more than a day.

Already tried a bunch of changes from different posts but I can’t see how to fix this. Hope you can help me finding the bug.

Thanks in advance.

EDIT: I just received this email from google after failing to send mails to a custom domain.

DNS Error: 49077003 DNS type ‘mx’ lookup of curimana.info responded with code SERVFAIL.

Will be looking for this errorcode fix.

P.S. Forgot to mention, when I run mx check tests, none of the domains hosted in the vps show a thing. They just say " Sorry, we couldn’t find any name servers for ‘hosteddomain.ltd’". So, there might be a problem with the DNS setup. Fck.

[email protected] ~ % nslookup curimana.info
;; Got SERVFAIL reply from 8.8.8.8, trying next server
Server: 8.8.4.4
Address: 8.8.4.4#53

** server can’t find curimana.info: SERVFAIL

[email protected] ~ %

So the DNS doesn’t exists.

Where do you host the DNS of the domains?

In the hestia panel as well. Let me attach a screenshot.

And this are the bind9 configs:

nslookup ventureops.agency so you can’t reach the name server ay more…

Well, when I test ventureops.agency, it fails. When I test the server: sv.ventureops.agency, I get some feedback.

Would it be suitable to run:
v-rebuild-dns-domain admin ventureops.agency
?

You could try it but I assume you have on 1 server that hosts your DNS records?

Yes, I only have this server and it hosts the DNS records and the websites as well.

After checking the NS records of the server FQDN (sv.ventureops.agency) and the original ltd (ventureops.agency) I’m a little scared.
Here says there is a loop and I don’t know what that actually means or what I should do.

Any idea why this would happen?

Probably the easiest method is create a account with Cloudflare and update the name servers there.

For hosting your own DNS servers you are almost mandatory to have 2 different servers. In cause one goes down you have always an alternative available…

1 Like

Does it mean I must update all the domains hosted with a new NS generated through CloudFlare? Or could they inherit the IP?


Fix EDIT.

In case anyone is having this problem: Domains hosted in your VPS are not pointing correctly to the Name servers or Mail servers when you lookup through tools like mxtoolbox.com or others.

What you can do is: reset the child-ns DNS.
How?

  1. Log into your panel hestia.yourdomain.ltd:8083

  2. Go to DNS

  3. Edit the domain DNS (not the server DNS).

  4. Update Template BIND9 from child-ns to default.

  5. Save

  6. Update Template BIND9 from default to child-ns.

  7. Save

  8. ???

  9. Profit

Well, seems like updating the template resets your DNS and adds the right values.

EXTRA STEPS:
In case you have edited the ns numbers to something different than 1 or 2, when you reset the DNS it will generate the ns1 and ns2 as NS and A records, if you want to use different ones, you will need to ADD the new ones, as you probably won’t be able to edit the auto-generated ones.

Hope this helps. Not needed to go to CloudFlare, tho that’s the recommended practice.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.