Note: Apache Update 2.4.55-1 (Ubuntu 18.04.6)

Today new packages for Apache are delivered under Ubuntu 18.04.6.

After that, websites may no longer be delivered via NGINX.

Affected updates:
Update to apache2 from 2.4.54-1+ubuntu18.04.1+deb.sury.org+1
to 2.4.55-1+ubuntu18.04.1+deb.sury.org+2

Update to apache2-suexec-custom from 2.4.54-1+ubuntu18.04.1+deb.sury.org+1
to 2.4.55-1+ubuntu18.04.1+deb.sury.org+2.

Best regards

Tom

1 Like

That is strange did you overwrote the apache2 config files?

That seems so. Because Apache now delivers its standard page authoritatively.

First aid:

With “Timeshift” to the status from yesterday evening.
In a quiet minute I will trigger the update manually instead of automatically as before.

For this reason I never like automated updates

I can confirm this. I had a few sites going down …

Apache2 did overwrote the conf during the update I did of Hestia web server. So was probally what went wrong

I ran the updates manually last night.

So I could prevent the configuration files from being overwritten and answer the questions with NO. With the automatic update, the same questions are answered with YES and that then triggers the “error”.

As eris has already described, the “local settings” must be preserved.

Otherwise, the following configuration will be overwritten:

‘/etc/apache2/apache2.conf’
‘/etc/apache2/ports.conf’

and
‘/etc/logrotate.d/apache2’

1 Like

How can an automatic update overwrite the config files? On my Debian server I updated apache2; I got the question if the existing config files should be replaced. Standard is always “No”. So the automatic update should not overwrite anything. I have automatic updates enabled in Debian.
Anyway, I’ll create a cron rclone of the apache config files, hestia.conf, roundcube configs and other.

Hestia does only update hestia, hestia-php and hestia-nginx packacage and never Apache2 or Nginx. How ever it happens every time when a user runs apt update && apt upgrade and the Apache2 and Nginx config is updated

Maybe I read something wrong there, but when I install “automatically” I don’t see any query.

But there are different possibilities for “automatic”
1.) check automatically
2.) check and install automatically
3.) check automatically and install manually

Hi Tom,
“when I updated” → I did it manually via apt. (Apt update, apt list -upgradable, apt upgrade). Apache2 was in the list and I got the message above. But I also have autoupdate & install activated in Debian, which is recommended for security updates. I’m not sure if the system would have updated apache2 itself. It’s autoupdate and autoinstall.