One domain keeps going offline because of SSL issues (2)

Topic was automatically closed, but the issue still persists:

I tried to renew the SSL certificate via terminal, so I can build a monthly cron to renew it automatically. I could delete it, then I tried to recreate it. In the web GUI SSL certificate and HSTS was ticked, but https redirection unticked:

v-delete-web-domain-ssl USER DOMAIN.TLD
v-add-letsencrypt-domain USER DOMAIN.TLD

  1. are these the correct commands?
  2. how to re-enable https-redirection via terminal? Is this possible?

Only when I deleted the certificate via the GUI and re-enabled it there, it worked again.

The problem is, if it’s not automated, e.g. via cron, it will happen again in the future.

Best, Michael


Yes, it is, the command is:

v-add-web-domain-ssl-force USER DOMAIN.TLD updatessl
1 Like

Hi sahsanu, thanks for your answer! With this command all three ticks are there and ssl is green, but still, the certificate doesn‘t work. Only if I re-issue it via the gui.

I forgot to mention that the website has a custom directory (subfolder). It‘s called web:
Absolute path:

I suppose the commands need to be adapted, but I don‘t see the option in the CLI reference. Do you know how it‘s done with a subfolder?

Best, Michael

Could you please share a couple of your real domains? If you don’t want to share them in public, send me a private message.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.