Override php-fpm settings

I’m trying to setup a php-fpm status page (fpm-status) so I would need to change a setting in the php-fpm pool file.
First I tried to update the 2 files in the /etc/php/7.4/fpm/pool.d directory: both domain.tld.conf and www.conf.
Then reading some posts in your forum, I tried to create 2 custom templates in the /usr/local/hestia/data/templates/web/php-fpm/ directory: default.tpl and PHP-7_4.tpl that I copied into custom_default.tpl and custom_PHP-7_4.tpl

Trying to open the url domain.tld/fpm-status a “not found” error keeps showing up…

Can you confirm which is the right way to override php-fpm settings in HestiaCP?


  1. The instructions you are mentioning, only indicates PHP-X_Y.tpl file… that means that we don’t need to copy default.tpl as well?

  2. What’s the meaning of “YOURNAME” in the YOURNAME-PHP-X_Y.tpl? is it the username under which runs the website? or is it the domain name used for the website?

You can’t modify the “default.tpl” but they are the same as PHP-7_4.tpl so it doesn’t matter

YOURNAME can be anything what you want

Looking up in Nginx error log, I see:
FastCGI sent in stderr: “Primary script unknown”

These are the commands I’m using to display php-fpm status page, is there anything wrong for HestiaCP there?

include fastcgi_params;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_pass unix:/run/php/php7.4-fpm-domain.tld.sock;

Found the culprit… php-fpm status page prefers the default name “status” instead of the custom one I was using (“fpm-status”)…