OwnCloud + VestaCP

Hi Team,

Does anyone have experience with OwnCloud installed on Hestia? I am seeing the following error messages and would like how best to address them as it seems to be with core configuration of PHP and file access. It also feels a big sluggish on a 32GB VPS. I think the “memcache” issue is the biggest problem.

Security & setup warnings

  • Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking. See the documentation :arrow_upper_right: for more information.

  • We recommend to enable system cron as any other cron method has possible performance and reliability implications.

  • Some files have not passed the integrity check. Further information on how to resolve this issue can be found in our documentation. ([List of invalid files…]

  • /dev/urandom is not readable by PHP which is highly discouraged for security reasons. Further information can be found in our documentation.

  • The “Strict-Transport-Security” HTTP header is not configured to at least “15552000” seconds. For enhanced security we recommend enabling HSTS as described in our [security tips]

  • No memory cache has been configured. To enhance your performance please configure a memcache if available. Further information can be found in our documentation.

Please double check the installation guides :arrow_upper_right:, and check for any errors or warnings in the [log]

Thanks for any tips.

  • /dev/urandom is not readable by PHP which is highly discouraged for security reasons. Further information can be found in our documentation.

When having an open_basedir configured within your php.ini file, make sure to include /dev/urandom .

Feel free to modify it your self but use templates instead…

https://docs.hestiacp.com/admin_docs/server_management.html#how-do-web-templates-work

  • The “Strict-Transport-Security” HTTP header is not configured to at least “15552000” seconds. For enhanced security we recommend enabling HSTS as described in our [security tips]

Currently set to 15768000 according to me its more then 15552000 by 2,5 days. Please enable the systems…

Install php-memcached or php-redis…

I don’t see any issues… How ever some TLC is required…

1 Like

Thanks for the reply. I installed Memcached from the CLI using “apt-get install memcached”

I then saw in the HestiaCP manual the following:

How to install additional PHP packages / Modules

apt-get install php-package-name

For example

apt-get install php-memcached php-redis

Will install php-memcached and php-redis including the required additional packages for PHP.

Incase you use PHP-FPM you don’t have to do anything.

I am using PHP-FPM set at “default”.

Though when looking at the PHP.INI i do not see any reference to memcache. I thought I would see

“extension=memcached.so”

Am i missing something? Or just add it manually.

I know perhaps my answer is not related but i install hestiacp + nextcloud nicely done and working

Thanks for the reply. Are saying you have no errors displaying? It works for me too, just I don’t feel that I should have so many errors. It does not feel optimised. It’s quite slow.(server is 32GB RAM, 4x CPU, SSD)

no worries, i think that is what this forum made for isn’t…we sharing and learn together

I installing using this way now, before I installing by downloading and unziping but there to many error.
check this install way

actually i copy this tutorial https://www.howtoforge.com/how-to-install-nextcloud-with-ispconfig/ but consider that hestiacp as the control panel :grin:

nicely specs that you have there, perhaps you also need to check the network latency beside the installation or the specs
just suggestion, maybe can help you out

1 Like