Password plugin: Hash method not supported

Hi

I just did a clean install of Hestia on a VPS with Ubuntu 22.04. I’m checking the modification of passwords for mail users, and at the time of making the change (Roundcube) appears the message Error 600.

The log says something like this: PHP Error: Password plugin: Hash method not supported. in /var/lib/roundcube/plugins/password/password.php on line 787 (POST /?_task=settings&_action=plugin.password-save)

Where should I make the settings to comply with the “Hash method”?

Hi @webcrafter72,

Could you please explain in detail what are you trying to do?

1 Like

Once I have created some mailboxes, I wanted to check the option to change the password inside Roundcube, but I get error 600.

Based on the log I have left, I am interested to know where to go to solve the problem.

Show the output of these commands:

grep 'plugins.*password' /etc/roundcube/config.inc.php
namei -mo /etc/roundcube/plugins/password/config.inc.php
grep -Ev '^\/|^$' /etc/roundcube/plugins/password/config.inc.php
$config["plugins"] = ["password", "newmail_notifier", "zipdownload", "archive", "managesieve"];
f: /etc/roundcube/plugins/password/config.inc.php
 drwxr-xr-x root root       /
 drwxr-xr-x root root       etc
 drwxr-x--x root hestiamail roundcube
 drwxr-x--x root hestiamail plugins
 drwxr-x--x root hestiamail password
 -rwxr-x--x root hestiamail config.inc.php
$config["password_driver"] = "hestia";
$config["password_minimum_length"] = 8;
$config["password_require_nonalpha"] = false;
$config["password_log"] = false;
$config["password_login_exceptions"] = null;
$config["password_idn_ascii"] = false;
$config["password_hestia_host"] = "paine.australmedia.cl";
$config["password_hestia_port"] = "8083";

Execute these commands and try again:

chown -R root:www-data /etc/roundcube/
find /etc/roundcube -type f -iname "*php" -exec chmod 640 {} \;
2 Likes

Wonderful!

I run a new test by updating the password inside Rouncube, saving the changes successfully; then, I try to access webmail and the new password works correctly. Great!

Thank you very much :metal: :sunglasses:

2 Likes

I had the same issue just now. This fixed it for me. Thank you @sahsanu :muscle:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.