Permission settings

How do I use or implement this, it seems that the solution is how it is done?

This was already released in hestia 1.3.1, so the issue should be fixed.

there will be some way that you see it maybe it is something simple that I cannot decipher (Skype, Telegram?)

Sounds like a custom issue, which isnt related to the filemanager. Probaly open a own thread about it and provide as much informations as possible. We do not provide any paid support services. IM service would be discord, but we expect a sysadmin it knowledge and can’t provide support for issues, that arent related to hestia itself.

but it works well it is a panel, I have installed it in a free hosting and it works I also have it in my paid hosting and it works only here it gives that error 403

Link demo :

demo hosting free

Link demo Hestia: demo hestia

demo another web in hestia root

but it works well it is a panel, I have installed it in a free hosting and it works I also have it in my paid hosting and it works only here it gives that error 403

Link demo :

demo hosting free

Link demo Hestia: demo hestia

demo another web in hestia root

I keep insisting because I liked him a lot, I just want that website to run, and it won’t be touched anymore

Please create an new topic and supply with more information:

What is you setup and stuff like that.

2 Likes

After two days of research I have discovered how to give permissions and I leave here the tutorial for those who are newbies like me and cannot find a way out.

  • Just to state the obvious for anyone viewing this discussion… if you give any of your folders 777 permissions, you are allowing ANYONE to read, write and execute any file in that directory… what this means is you have given ANYONE (any hacker or malicious person in the entire world) permission to upload ANY file, virus or any other file, and THEN execute that file…

IF YOU ARE SETTING YOUR FOLDER PERMISSIONS TO 777 YOU HAVE OPENED YOUR SERVER TO ANYONE THAT CAN FIND THAT DIRECTORY. Clear enough??? :slight_smile:

There are basically two ways to setup your ownership and permissions. Either you give yourself ownership or you make the webserver the owner of all files.

1- First way

Webserver as owner (the way most people do it, and the Laravel doc’s way):

assuming www-data (it could be something else) is your webserver user.

sudo chown -R www-data:www-data /home/ *your_username* /web/ *your_domain* /public_html

if you do that, the webserver owns all the files, and is also the group, and you will have some problems uploading files or working with files via FTP, because your FTP client will be logged in as you, not your webserver, so add your user to the webserver user group:

sudo usermod -a -G www-data ubuntu

Of course, this assumes your webserver is running as www-data (the Homestead default), and your user is ubuntu (it’s vagrant if you are using Homestead).

Then you set all your directories to 755 and your files to 644… SET file permissions

sudo find /home/ *your_username* /web/ *your_domain* /public_html -type f -exec chmod 644 {} \;

SET directory permissions

sudo find /home/ *your_username* /web/ *your_domain* /public_html -type d -exec chmod 755 {} \;

then in panel hestia settings, restart server with that everything will be resolved

2- Second way

this is the one I preferred to use

Your user as owner

I prefer to own all the directories and files (it makes working with everything much easier), so I do:

sudo chown -R my-user:www-data /home/ *your_username* /web/ *your_domain* /public_html

Then I give both myself and the webserver permissions:

sudo find /home/ *your_username* /web/ *your_domain* /public_html -type f -exec chmod 664 {} \;
sudo find /home/ *your_username* /web/ *your_domain* /public_html -type d -exec chmod 775 {} \;

then in panel hestia settings, restart server with that everything will be resolved

With this we say goodbye to the permission problem that frustrates us so much and takes away our sleep

I have a web that uses .htaccess and it seems that it does not recognize it, a simple html if it works

I’ve been trying to fix that for more than 12 hours and I can’t do it

I would like a hand here I have used the permissions of the tutorial that I have posted above, everything works very well except the file manager, now it shows all the directories, does anyone know how I can solve this problem?

every user can see this

Please stop to fill up a 4 month old thread… I’ve moved now your posts to a new topic.

For the last one: You set the user probaly to bash or any other shell access in your settings - set him to nologin to get sftp jail active which will limit aswell the filemanager to the home dir.

2 Likes