PHP Memory Size (\NextCloud)

I have installed Nexcloud to use for my own business and I have been using it for a while.
I already updated and upgraded the operating system ubuntu.
but there is an update for Nexcloud which I cloud not apply due the memory size issue of PHP.
“The PHP memory limit is below the recommended value of 512MB.”

Also whenever, I delete files from Nextcloud the storage usage isn’t changing.

Kindly check attachments and extend your support it is really important to me.
As it is affecting my business storage and security…

Thanks in advance.

open /etc/php/x.x/fpm/php.ini where x.x is the memory limit

Look for php_memory_limit and change it and restart phpx.x-fpm

2 Likes

Thank you very much that solved my issue.
However, still when I delete files disk usage isn’t changing or reducing.

You should create an issue at Nextcloud / Hanabicloud what the issue issue is… I don’t know how the check the diskusage

Thank you very much,
I have submitted that on NextCloud help portal.
Hopefully I get an answer

ive noticed there is a lag on the deleted files to update ,
try loggin out and in again and check to see if the file uages has refreshed ,

this is most certainly a NC issues nothing to do with hestia

A couple of things about Nextcloud data storage.

  1. It keeps backups every time you run the upgrader. Those are about 700MB each. You’ll find them in a folder called data/updater-poaidsfapaidfa/backups or something like that. You may want to delete some of those.
  2. Nextcloud will retain several ‘revisions’ of each file. So when you delete a file, it isn’t actually deleted. You may want to look into the setting the number of revisions it keeps.
    Version control — Nextcloud latest User Manual latest documentation