Php8.1-fpm does not work

I stopped working php8.1-fpm

I restart it, I get the result: Error: ERROR: Restart of php8.1-fpm failed.

I can enter template edit mode and when saving it does not give an error.

I checked the site template: /usr/local/hestia/data/templates/web/php-fpm/PHP-8_1.tpl

Didn’t find any changes.

I checked /etc/php/8.1 Folders and files in place. Until recently everything was working.
PHP system version in main settings 8.1

I tried to manipulate php versions in packages and domains to fix the error. But this only led to the fact that the error began to give php8.0-fpm, php8.2-fpm

I did not find in the panel logs an indication of an error when restarting php8.1-fpm

Any ideas, thanks?

systemctl status php8.1-fpm

systemctl restart php8.1-fpm

The result of this command is the following:

After getting the error I removed /etc/php/8.1/fpm/pool.d/file.conf

After that I got the following error:

I ended up deleting all the config files that gave value is null.

As far as I understand, the config files remained in the /etc/php/8.1/fpm/pool.d/ folder after I changed the frm template in the domain.

And as I understand it, when changing the template, the panel should have deleted the old config files and created new ones in the new frm template.

I checked and saw new entries in the frm template I am now using. But for what reason the old ones were not removed, I do not know.

After deleting the config files in a template that no longer owns a domain, I got a working php8.1-fpm template again.

I returned one domain per php8.1-fpm template to test the template.

And I got again the same error, although the domain is on php8.1-fpm.

If I change the frm template again on the domain from 8.1 to another one, the 8.1 template works.

What further actions can I take to make 8.1-frm work?

Check the contents of the template you are using it looks like there is a bug with it

/usr/local/hestia/data/templates/web/php-fpm is the folder

I ended up doing the following. I have removed all php 8 templates.
v-delete-web-php 8.0
v-delete-web-php 8.1
v-delete-web-php 8.2

And I reinstalled them.

v-add-web-php 8.0
v-add-web-php 8.1
v-add-web-php 8.2

Now everything works correctly. Thanks for support.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.