PHPMyAdmin 404 with remote DB server

Trying to set up PHPmyadmin to connect to a remote MySQL server. I’ve installed phpmyadmin, and configured it to connect to the remote server, however when I visit panel.domain.tld/phpmyadmin I get a 404. I can’t seem to get around it.

Hestia Control Panel version:
Ubuntu 20.04 (x86_64)

Any help appreciated.

If mysql was enabled during install phpmyadmin might allready be installed in /usr/local/share/phpmyadmin and rules for it will get loading in /etc/apache2/ or /etc/nginx/

If the first thing has been happened:

cp /etc/phpmyadmin/conf.d/01-localhost.php /etc/phpmyadmin/conf.d/02-server.php

And update the values should be enough

Thank you for the response.

The conf file didn’t exist, so I created it. still 404s.I double-checked the config locations for both Nginx, and apache and it exits in both. I am not sure which webserver engine is driving the 404. But it does seem like the actual configs are not being loaded. even though the files are present.

(I originally interspersed this with screenshots, but I am not allowed. So I have included them in an Imgur gallery PHPMYADMIN Woes - Album on Imgur

I hope this helps.

We use custom configs

So sites-enabled folder is never enabled.


That is also present on my server.

It is taken from the same file…

You need put the config files in conf.d … Otherwise it will never work…

so copy phpmyadmin.conf into conf.d?

ok! so doing that, the client domains /phpmyadmin started working. the main panel URL /phpmyadmin is not (which is the one linked from the Hestia UI.

main domain needs to be added as well to Hestia …

By default we have disabled http://ip/phpmyadmin/

it is, yep!

Then it should be the same as

I have no ideas why it doesn’t work…