PhpMyAdmin 504 Gateway Timeout error when importing Database

I am aware, that there are similar topics on this forum already, but unfortunately this issue never got solved.

When uploading a 6MB zip packed sql database i get an timeout error. apache and php settings are set to handle fileuploads much larger than this. (unpacked database is 180MB)

I would like to use hestia because it is a graphical tool to manage servers, so using the CLI to get things done is a workaround, but not really a solution.

does anyone know why this timeout happens so it can be properly fixed?

PHP execution times.

Faster CPU
Increase timeouts
Split SQL into different chunks

Well, yes, but i see an irregularity of software behavior on the very same server.

Running the exact same import on Webinoly, AAPanel, or CyberPanel, will just work. Even with the same timeout settings in PHP (standard execution time 30s)

Looking at the overall workload, it only takes 5 seconds for the CPU to process the import.
4x 2,5 Ghz is enough for such an easy task, even if PHP only uses 1 CPU for execution.

Hence i believe there is another underlying issue here.

Then we can’t help you if you don’t provide debug information.