Phpmyadmin - missing hestia v1.5.2 - New Install

Hi All,

Been a while since i used hestia and it seems that i lost my way around it, on new install the phpmyadmin is not reachable at my domain/phpmyadmin

i installed this on an digitalocean droplet ubuntu 20.04 with the default command

Any idea why is this happening .

JP should work fine.

We have disabled http://ip/phpmyadmin

I’m lost to be fair as i point to a domain, and same result

When disabled some how the link in the panel should have been looked at and auto update for the type of guy’s like me :slight_smile:

So my domain is pointing to the vps all good i can even see the welcome message if i go without the phpmyadmin.
Success! Your new web server is ready to use.

So what i’m missing in all this

Wait is for each individual domain not the host panel domain

Try this

Domain need to exists on the server…

Success! Your new web server is ready to use. Is only that the server is posting to the server but not resolving it correctly


Managed to connect to a domain added to the server (not the panel one)
ok fair enough, but what when you move a exiting live domain and you don’t want the down time, how do you import the existing database if you can’t connect without the domain pointing to the new install

Should not the hostname also be allowed to be able to facilitate the above.


if is cp.domain.tld added as web domain in admin user, it will work. For migration parts i anyway would do the export and import of mysql dbs over cli using mysql(dump).

Thank you all, this is a big reason why this community is great.

Indeed the above helped me out.

Side note might be good idea to implement the button/link in the control panel for the phpmyadmin to link you to the domain you are in instead to the ip, to avoid confusion, for people like me, lees agile on this :slight_smile:

If you use a valid hostname to access your control panel it works as intended…

How do i manually import a mysql database with cli command given the fact i have the below details

Mysql database (mariadb) database name is DBCustom and database username is DBCustom and the password is PassordDB and hostname is localhost

reason for this i have 300mb sql that cloudflare will not let me upload trough their cdn so i used this time Navicat for MariaDB to remote do it but be goot to know how can i do it in CLI

Basic admin things: Use scp and real ips for transfer the sql file and mysql with root user, usualy you can run it without any password, its saved in /root/my.cnf

Use MySQL dump


In this way the automatic login function (hestia-sso.php) becomes useless in the admin panel:
https: // ip: 8083 / list / db /

When you press the phpmyadmin buttons you will see PAGE NOT FOUND (ie … the function does not work)

In fact, the most reasonable thing that seems to me and would work is:
when trying to log in to phpmyadmin regardless of:
ip / phpmyadmin

Just index.php of phpmyadmin should check if the visitor is already logged in hestia, ie. is there a session created for the hestia login.

Recent hestia updates have made phpmyadmin available through every, but I don’t think that’s a safe option either.

This is my personal opinion because I believe that in the discussions there are solutions to our sometimes … so simple problems.

Happy New Year. I hope the team here is healthy and more successful than ever!

P.S. By the way, how can I make a donation to the project?

By default should also work…

If you keep using it should still work fine …

If you want to keep the old behaviour:

  • NOTE: Changes have been made on how phpmyadmin/phppgadmin config are included in apache2 config. To restore to the old behaviour add IncludeOptional conf.d/*.inc below IncludeOptional conf.d/*.conf in /etc/apache2/apache2.conf and restart your server.


Bitcoin : bc1q48jt5wg5jaj8g9zy7c3j03cv57j2m2u5anlutu
Ethereum : 0xfF3Dd2c889bd0Ff73d8085B84A314FC7c88e5D51
Binance: bnb1l4ywvw5ejfmsgjdcx8jn5lxj7zsun8ktfu7rh8
Smart Chain: 0xfF3Dd2c889bd0Ff73d8085B84A314FC7c88e5D51

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.