PhpMyAdmin root user lacking some privilages

I had an issue that prevented me from editing and exporting Routines stored in databases. So I assumed it was because normal users doesn’t get these privilages by default.

So I logged in as root, and tried again. To my surprise, the same issue persisted with the root user too.

When I checked if I can edit the user permissions, the User Accounts Tab is showing “Not enough privilege to view users”.

I don’t understand why even the root user doesn’t have the permission to view or edit other users’ permissions, or even the basic permission to edit or export a stored procedure in routines tab.

If anyone could help me solve this, I’d be really greatful.

Thanks in advance.

I don’t have any issues using root use to see the user accounts:

Hi do you have any idea why this might be like this? Or is there any way to solve this?

Login with mysql
use mysql;

And check if it has the correct permissions first…

Just now I tried the steps mentioned in the link you shared. But while executing the query on step 4, I’m getting the error: The user specified as a definer (‘mariadb.sys’@‘localhost’) does not exist.

I tried to open the table mysql.user but it’s showing a blank screen.

Hi, anyone with a solution? Maybe reinstalling the phpMyAdmin/MySql? How do we do that in Hestia?