Phpmyadmin SSO not working

Hestia v1.8.11 on Ubuntu 22.04. Fresh install. Have some other servers running which work as expected (same software versions).

I try to enable phpmyadmin SSO. Everything looks fine and I do see SSO users being created in MySQL. But when I use the SSO links I end up on a login page.

Tried multiple times to disable and enable SSO. No errors in logs as far as I can see.

Who can help me out? I am almost sure I miss something. Thanks!

Did you follow the troubleshooting steps?

Yes, but no errors found.

Show the output of this command (as root):

v-list-sys-config json | grep API_ALLOWED

v-list-sys-config json | grep API_ALLOWED

Same as on a server which is working, also tried to add my public IP to the allowed IP’s without luck.

Ok, then if you can’t see any error in the logs, I’ve no idea what’s going on.

Check /var/log/nginx/domains/domain.error.log or /var/log/apache2/domains/domain.error.log

FInally got an error:

[Wed Jan 10 16:02:40.413943 2024] [proxy_fcgi:error] [pid 56180:tid 139853144462912] [client x.x.x.x:0] AH01071: Got error 'PHP message: PHP Warning:  Link has been expired: System time: 1704898960 / Time provided in link: 1704898887
 in /usr/share/phpmyadmin/hestia-sso.php on line 200', referer: https://x.x.x.x:8083/

No idea what happens, but there is something with the time? I already tried to refresh the page and use another browser without luck.

Refresh the page and try again

Does not work. Also cleared cache and used other computers and browsers. All without luck.

In this case:

1704898960 - 1704898887 = 71 sec that would explain the issue as it more then 1 min …

I know, but I cannot explain the difference.

Decided to reinstall the server today, same issue… Even while another installation on Ubuntu 22.04 has no issues. Only difference, this Ubuntu image has a group “admin” and I need to use force installation.

Managed to get it working!

I did run the manual phpmyadmin installation script. SSO started to work, but within phpmyadmin an pma password error. Replaced the password of the pma user with the one found in the phpmyadmin conf and it is working as expected now!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.