[Poll] How has your experience been with Hestia Control Panel 1.8.3?

Hello everyone,

We want to know how your experience has been with the latest release of Hestia Control Panel, version 1.8.3. Please feel free to leave a comment and share your experience with our development team.


I installed Hestia 1.8.2 on a new Debian 12 VPS. I then tried to log in using the suggested URL


The browser replied:

Hestia Unable to connect… An error occurred during a connection to ns1.xxx.com

I tried this with several browsers with the same result.

I was able to log into the new panel with the backup URL which was


Everything seemed to work OK. But I logged out and tried again to log in with the primary FQDN and still no luck.

I have checked to make sure the A record for ns1 was properly set for the correct IP address.

Any advice to resolve this problem would be greatly appreciated.

nslookup ns1.xxx.com reports the server ip address?

1 Like

You solved my problem. It turns out the IP address was not a clean IP address. It was a recycled IP address. I have reported the problem to the VPS host and I am confident that once they clear the old DNS records, the domain name log in will work properly.

I am extremely happy and grateful to be using Hestia with Debian 12. However, there was a strange thing that happened with Hestia 1.8.2 which did not happen with my other servers using Debian 11. When I logged into the admin panel and clicked on Settings, all nine versions of php-fpm were shown from 5.6 to 8.2 in the Services column. My other panels just show the PHP versions I am actually using (which was 8.1) in the Services column. It is not a biggy but is there any way to fix this problem? Would it hurt anything if I just deleted all of the older versions of PHP?

Did you install with the --multiphp flag by chance? Either way, it’s safe to remove the versions you don’t need either from the panel under Server Settings > Configure > Web Server or run v-delete-web-php {version} from a terminal session.

I did not see any option to remove a PHP version at Server Settings > Configure > Web Server. I unchecked PHP 5.6 and clicked Save and it removed 5.6 from the Settings services list. But it was still shown in the Web Server list.

I then tried to uncheck PHP 7.0 and 7.0 but was met with a wall of errors. I then tried a terminal session as root with

v-delete-web-php 7.0

However, the terminal replied:

Uninstallation failed, please run the following command manually for debugging:

apt-get purge php7.0-common php7.0-mbstring php7.0-bcmath php7.0-cli php7.0-curl

php7.0-fpm php7.0-gd php7.0-intl php7.0-mysql

php7.0-soap php7.0-xml php7.0-zip php7.0-mbstring

php7.0-json php7.0-bz2 php7.0-pspell php7.0-imagick php7.0-pgsql

php7.0-imap php7.0-ldap php7.0-mcrypt

I then copy pasted the suggested command above into the terminal but was met with this reply:

E: dpkg was interrupted, you must manually run ‘dpkg --configure -a’ to correct the problem.

-bash: php7.0-fpm: command not found

-bash: php7.0-soap: command not found

-bash: php7.0-json: command not found

-bash: php7.0-imap: command not found

I have therefore decided to reinstall Debian 12 and then install Hestia but with the multiphp option turned off.

Really appreciative about the activity and new features coming in steadily.

Overall, the UI is becoming more polished, which is a welcome happening. I haven’t experienced any groundbreaking issues since upgrading, so fingers crossed! I did however notice that the search function doesn’t work in 1.8.2, but this has already been addressed.

The move to a forum instead of the crowded Discord channels was also a good change I think :slight_smile:

Thank you for all your hard work!


It has been wonderful.

1 Like

I have disabled auto update on several servers while waiting for it to be more stable. Hopefully it is stable as of 1.8.2

The experience is great i a using this on Vps in South Africa

1 Like

there were not much issues in 1.8.0, also they had been resolved in 1.8.1 which has been shipped directly. Its save to upgrade to 1.8.2.

1 Like

I must say I love this Control Panel.
I am new to this, coming from windozes :relieved:
Best Regards

1 Like

i’m on ARM and its running flawlessly


I self host on my residential isp uplink and dont make money like some do from hestiacp, i have used this great software for years and i am happy and am thankful for your time in developing this great webhost solution.

My issues and not related to hestiacp but spamhaus pbl, stopping people wanting to self host from home and sending emails to the likes of hotmail, i understand its about cutting spam but its forces people to rent vps/dps or buying a relay service.

The issues i have noticed self hosting are file manager never works even on new installs, recently i can not access the panel panel.url.com when you put the password in it goes back to username but works when logging in locally (local lan).

For some reason the firewall bans my router, i have tried several older routers and a udm pro it still bans

But thats an issue i have sorted wit ignoreip in fail2ban.

Other than that i love what you guys are doing and I love the way fossbilling is going (already works with hestiacp), i only looked at foss billing because i follow some devs on github.

I would love to see clusterinh at some point in the future of hestiacp, to manage a full cluster of hestiacp servers but thats would be way way way in the future

Great job guys keep up the hard work i am very greatful for you time, effort, energy and love you put into hestiacp

is there a changelog for 1.8.4 beta?


  • Fixed an issue where logs entries would be duplicated when calling return_hash (#3869)
  • Modified installer behavior so that firewall rules are only added for necessary services (#3871)
  • Minor adjustments to styling and classes (#3843)
  • Improved robustness of v-list-sys-themes (#3842)
  • Minor updates to v-update-mail-domain-ssl (#3850)
  • Changed default PHP-FPM version to 8.2 (#3861)
  • Minor updates to v-generate-password-hash (#3874)
  • Fixed an issue that would occur during installation if Cloudflare IP address range could not be updated (#3876)
  • Fixed multiple PHP warnings and 500 error when mail was not installed (#3841, #3877)


  • Removed typescript from the project for simplicity (#3821)
  • Removed PostCSS and move to Lightning CSS (#3820)
  • Updated translations (#3878)
  • Updated dependency eslint to v8.46.0 (#3881)
  • Updated dependency esbuild to v0.18.16 (#3826)
  • Updated dependency stylelint to v15.10.2 (#3829)
  • Updated dependency chart.js to v4.3.2 (#3866)
  • Updated dependency hestiacp/phpquoteshellarg to v1.0.1 (#3827)
  • Pinned dependency @fortawesome/fontawesome-free to 6.4.0 (#3862)
  • Updated renovate config (#3840)
  • Updated all non-major dependencies (#3880)

Also the same as the release :slight_smile:

1 Like

installed yesterday so far so good without problem easy manageable in arm with ubuntu keep it up and thank you