Port conflict on port 9000 with multi php-fpm

Here the same port is assigned in php-fpm 7.4 and 8.0:

/etc/php/7.4/fpm/pool.d
/etc/php/8.0/fpm/pool.d

[www]
listen = 127.0.0.1:9000

You probaly speak about the www.conf file, this should be only placed once.

@ScIT
Uh, forgot to include it. Yes, that it the only place. (in my installation, I lowered the port number of 7.4 below 9xxx. to have no conflict with 8.x.

The newly created domains in the new installation got inserted with 8.0 php-fpm. Importing from the hestia backup, they got into php-fpm 7.4.

But I wonder if there is a script to change php-fpm from 7.4 to 8.0. I think it could be helpful, if not in there. (I am not yet through to find out if there is a script to change this.)

There is a script to “update” from any version to any version in:

or when no multiphp is enabled:

Should also do the trick

Hello Eris,

Thanks.

I have multiphp enabled but now want to use only 8.0. So I did a simply upgrade of php, which of course delete the php 7.4 from the system.

After 7.4 was removed, I got 503 error. I checked here:

https://1.2.3.4:8888/edit/server/
—> Configure Server
—>—> Web Server
—>—>—> Enabled PHP versions

All the user.conf had 7.4 in there. So I substituted:

/usr/local/hestia/data/users/username/web.conf
BACKEND=‘PHP-7_4’
to
BACKEND=‘PHP-8_0’.

Now, I am working on why I get 503 error. Perhaphs, I will have to restart the server, although 8.0 was already installed.

Don’t forgot to rebuild web domains for that user.

Hi Eris,

Yes, thanks. I now see that rebuild have spared my time of manual substitution in the user.conf. I have to learn quite a lot and remember much.

The 503 error has nothing to do with Hestia scripts coding directly. This is a local or my problem. The phpinfo works outside of a subdirectory but not inside. During checking, the phpinfo script was inside a protected subdirectory, which gave 503. I will have to find out why and where I should change.

Thanks again.

Hi Eris,

Now I know why I got 503 error.

User rebuild did not substitute the backend template from PHP-7_4 —> PHP-8_0. Either I needed to go through the php scripts or search and replace like I did above.

But the /run/php/ has no files. It is empty! Thus, I get 503. I have no idea why and how this happened. I did the upgrade_php.sh. I was asked to execute apt autoremove, which I did. It had removed some php 7.4 binaries.

v-update-web-templates generates all files successfully. Further, I can systemctl restart php8.0-fpm successfully. All conf files in /etc/php/8.0/fpm/pool.d are there.

Any suggestion on how I can regenerate the files under /run/php/?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.