Prestashop install -php error

Hello, I installed multiphp, but I fail to make it work presashop. no matter what method I install it gives me error.

[Tue Jun 30 15:22:01.206104 2020] [proxy_fcgi:error] [pid 30150] [customer] AH01071: Got error ‘PHP message: PHP Fatal error: Uncaught SymfonyComponentCacheExceptionInvalidArgumentException: Cache key must be string, “NULL” given in /home/exeplus/web/ trace:n#0 /home/exeplus/web/ dor/symfony/symfony/src/Symfony/Component/Cache/Traits/AbstractTrait.php(235): SymfonyComponentCacheCacheItem::validatedKey(NULL)n#1 /home/exeplus/web/ mfony/src/Symfony/Component/Cache/Adapter/AbstractAdapter.php(152): SymfonyComponentCacheAdapterAbstractAdapter->getId(NULL)n#2 /home/exeplus/web/ ion/CLDR/DataLayer/LocaleCache.php(82): SymfonyComponentCacheAdapterAbstractAdapter->getItem(NULL)n#3 /home/exeplus/web/ : PrestaShopPrestaShopCoreLocalizationCLDRDataLayerLocalECache->doRead(NULL)n#4 /home/exeplus…’

Hi @axisdigital

Basicly we can’t support third party software - but can you provide more informations so we can have a look? For example OS-, Hestia-, used PHP-Version, how you installed prestashop and so on? Basicly this is the minimum if you want to have help :slight_smile:.

of course, thank you.
hestiacp-1.2 / multiphp (7.3) / Quick Install App (hestia panel) … / Debian10
Click “setup” prestashop …

I understand that Prestashop does not yet support PHP 7.3, according to my tests you should change it to 7.1

I tried, all versions … but does not work the same error … I can’t figure out what

I am not an expert in Prestashop but I have had to configure it several times and the truth is that it gives many incompatibilities at first. I recommend that you download a script called PhpPsInfo - PrestaShop system requirements checker and check that everything is ok, if not you can also ask in the Prestashop forum and I’m sure there is someone who has the same problem as you.

I would suggest to give a try with a manual installation from source or according their docs - so you can see if it is a issue with the one click installer or prestashop itself.

If I’m not wrong then you’re using nginx + php-fpm while to install PrestaShop you need apache as backend…

no, I only use apache without nginx, now I try to install manually.

Increase mysql timeout from 10 sec to something more appropriate like 30s or 60s with cli or webui (:8083/edit/server/mysql/)

# max_allowed_packet = 128M # Optional increase this value too

Prestashop is loading some sample data during install and if the server isn’t fast enough mysql will terminate the query.


thank`s :slight_smile: problem is wait_timeout=60 …